Edgewall Software
Modify

Opened 14 years ago

Closed 13 years ago

#3269 closed enhancement (duplicate)

cc only on substantial changes

Reported by: fumanchu@… Owned by: Jonas Borgström
Priority: normal Milestone:
Component: ticket system Version: 0.9b1
Severity: normal Keywords: cc notification email
Cc: Branch:
Release Notes:
API Changes:

Description

We've started using Trac for generic project management at my company. I've got several custom fields for tracking hours worked, estimates, cost, etc. These all work great.

Partly due to the number of custom fields, some of my users have complained that the number of emails being sent from Trac is overwhelming, to the point of "boy who cried wolf" syndrome; that is, they're being deleted without being read. I think the majority of that complaint can be resolved in my case by sending notifications to names in the CC list only if the ticket.get_changelog() contains 'comment' or 'description' changes. The owner and reporter will still be notified on all changes.

Patch attached which uses a config entry to accomplish this.

Attachments (1)

cc_on_comment.diff (2.0 KB ) - added by fumanchu@… 14 years ago.
Notify cc recipients only on certain field changes

Download all attachments as: .zip

Change History (3)

by fumanchu@…, 14 years ago

Attachment: cc_on_comment.diff added

Notify cc recipients only on certain field changes

comment:1 by Emmanuel Blot, 14 years ago

Keywords: notification email added; notify removed

If you want to submit patches, please submit them against the trunk if the patch is about a new feature.
The branches/0.9-stable development branch is for bug fixing only, and won't support new feature.

Unfortunetaly, the notification code has been somewhat reworked from 0.9 to 0.10, so there are few chances the patch can be integrated into the current code base.

See also #1459.

comment:2 by sid, 13 years ago

Resolution: duplicate
Status: newclosed

Looks like a duplicate of #2073 and #4056.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Jonas Borgström.
The resolution will be deleted. Next status will be 'reopened'.
to as closed The owner will be changed from Jonas Borgström to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.