Edgewall Software
Modify

Opened 15 years ago

Closed 15 years ago

Last modified 15 years ago

#3101 closed defect (fixed)

smtp_always_cc ignored unless Trac would already be sending an email

Reported by: Tim Hatch <trac@…> Owned by: Christopher Lenz
Priority: highest Milestone: 0.10
Component: ticket system Version: devel
Severity: major Keywords: smtp_always_cc notification email
Cc: Branch:
Release Notes:
API Changes:
Internal Changes:

Description (last modified by Christian Boos)

This is a regression from the fix for #3057 which occured in r3231. Basically if a ticket has someone in the Cc: field, then it works fine and picks up the smtp_always_cc values as it should. However, if the Cc: field is blank, ticket/notification.py bails with the message

2006-05-01 13:08:22,117 Trac[notification] INFO: no recipient for a ticket notification

Before giving up, it should see if there are any email addresses in smtp_always_cc (and now smtp_always_bcc, which I didn't add), if those config options exist. I've made a patch for smtp_always_cc which solves the problem in my case, since I don't use bcc.

The full fix should check both cc and bcc, however now that there are two lists of addresses to check, I wonder if the "bail, no reason to notifiy" check should be moved to trac.notification instead of trac.ticket.notification?

Attachments (1)

trac-notification-always-cc-broken-in-r3231.patch (689 bytes ) - added by Tim Hatch <trac@…> 15 years ago.
Rough patch against trunk (r3257)

Download all attachments as: .zip

Change History (5)

by Tim Hatch <trac@…>, 15 years ago

Rough patch against trunk (r3257)

comment:1 by Christopher Lenz, 15 years ago

Owner: changed from Jonas Borgström to Christopher Lenz
Status: newassigned

Thanks for the patch!

I think we'll also need to check smtp_always_bcc.

comment:2 by Christopher Lenz, 15 years ago

Resolution: fixed
Status: assignedclosed

Modified patch applied in [3273].

comment:3 by Emmanuel Blot, 15 years ago

(non-regression test added in r3280)

comment:4 by Christian Boos, 15 years ago

Description: modified (diff)

(fixed description formatting after deletion of a "test" comment)

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Christopher Lenz.
The resolution will be deleted. Next status will be 'reopened'.
to The owner will be changed from Christopher Lenz to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.