Edgewall Software
Modify

Opened 15 years ago

Closed 15 years ago

#3039 closed defect (duplicate)

Trac crashes Apache with mod_python under Windows 2000

Reported by: vdenisov@… Owned by: Jonas Borgström
Priority: normal Milestone:
Component: general Version: 0.9.4
Severity: major Keywords: crash
Cc: Branch:
Release Notes:
API Changes:
Internal Changes:

Description

I'm running Trac 0.9.4 on Windows 2000 with Apache 2.0.55 with mod_python 3.2.8. About 2 or 3 times per day Apache crashes with the following error (loosely translated from Russian) popping up at the console:

Instruction at address 0x1e05db6f accessed memory at address 0xd8ebc005. Memory cannot be read

Because of this message, Apache service doesn't restart automatically (the process isn't really terminated till I click on Ok button), which is obviously bad.

Until recently, this bug had affected other developers working on our project, but now I've seen it as well. I've just logged in to Trac, clicked on the "Timeline", and Trac output the following in the browser:

Trac detected an internal error: 

argument to += must be iterable

with Python traceback:

Traceback (most recent call last):
  File "C:\Python23\lib\site-packages\trac\web\modpython_frontend.py", line 206, in handler
    dispatch_request(mpr.path_info, mpr, env)
  File "C:\Python23\lib\site-packages\trac\web\main.py", line 139, in dispatch_request
    dispatcher.dispatch(req)
  File "C:\Python23\lib\site-packages\trac\web\main.py", line 107, in dispatch
    resp = chosen_handler.process_request(req)
  File "C:\Python23\lib\site-packages\trac\Timeline.py", line 140, in process_request
    filters)
TypeError: argument to += must be iterable

Unfortunately, the logging wasn't turned on at the time, I'll turn it on ASAP and will try to reproduce the error again. I'll add more details if I'll succeed.

Its worth noting that this same Trac site had ran for about a month and a half in CGI mode, without any problems whatsoever, so this is mostlikely either a mod_python or a threading issue.

If I can help to troubleshoot this in any way, just let me know.

Attachments (0)

Change History (5)

comment:1 by Alec Thomas, 15 years ago

Is this two separate errors or one?

The invalid memory read is not really anything to do with Trac, as pure Python code should never be cause an error like that. It is indicative of a bug in one of the C components such as mod_python, Apache, sqlite, etc.

As for the second error, if it was not triggered as a result of the first issue then it could indicate a plugin is returning invalid timeline data. Try disabling all of your third party plugins.

comment:2 by anonymous, 15 years ago

Resolution: invalid
Status: newclosed

comment:3 by Emmanuel Blot, 15 years ago

Resolution: invalid
Status: closedreopened

Please do not close a ticket as "invalid" without providing some details (moreover, without identifing yourself).

vdenisov: which authentication scheme are you using ?

comment:4 by Christian Boos, 15 years ago

Keywords: crash added
Severity: normalmajor

In the same vein as the above, about the first issue, is this Apache server dedicated to Trac or is it also used for other purpose, with other modules?

For the second error, looks like you have an error very similar to #2965, as they were using the same setup as you (apache 2.0.55/windows + mod_python 3.2.8). Maybe you have the same issue related to virtual hosts…

If yes, please close this ticket as duplicate and follow-up there.

Also, if you can test 0.10dev, check out r3157, which tries to give you a more informative message in case the python exception happens.

comment:5 by vdenisov@…, 15 years ago

Resolution: duplicate
Status: reopenedclosed

Ok, since my setup is similar, I'm following up in ticket 2965

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Jonas Borgström.
The resolution will be deleted. Next status will be 'reopened'.
to The owner will be changed from Jonas Borgström to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.