Edgewall Software
Modify

Opened 15 years ago

Closed 15 years ago

#2995 closed defect (duplicate)

Attach File doesn't work!

Reported by: anonymous Owned by: Jonas Borgström
Priority: normal Milestone:
Component: web frontend/mod_python Version: 0.9.4
Severity: normal Keywords:
Cc: Branch:
Release Notes:
API Changes:
Internal Changes:

Description (last modified by Christian Boos)

Traceback (most recent call last):

  File "C:\Python23\lib\site-packages\trac\web\modpython_frontend.py", line 206, in handler
    dispatch_request(mpr.path_info, mpr, env)
  File "C:\Python23\Lib\site-packages\trac\web\main.py", line 139, in dispatch_request
    dispatcher.dispatch(req)
  File "C:\Python23\Lib\site-packages\trac\web\main.py", line 107, in dispatch
    resp = chosen_handler.process_request(req)
  File "C:\Python23\Lib\site-packages\trac\attachment.py", line 267, in process_request
    self._do_save(req, attachment)
  File "C:\Python23\Lib\site-packages\trac\attachment.py", line 298, in _do_save
    if not upload.filename:
AttributeError: 'StringField' object has no attribute 'filename'

Attachments (0)

Change History (1)

comment:1 by Christian Boos, 15 years ago

Component: generalmod_python frontend
Description: modified (diff)
Resolution: duplicate
Status: newclosed

Duplicate of #554. See TracModPython#Win32Issues for a solution to this known issue.

P.S. a search for 'StringField' object has no attribute either on Trac or on Google (even with I'm feeling lucky :) ) would have shown an appropriate answer…

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Jonas Borgström.
The resolution will be deleted. Next status will be 'reopened'.
to The owner will be changed from Jonas Borgström to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.