Edgewall Software
Modify

Opened 14 years ago

Closed 14 years ago

Last modified 17 months ago

#2897 closed defect (invalid)

Timeline not updated when Ticket is changed

Reported by: mjlucas@… Owned by: Jonas Borgström
Priority: normal Milestone:
Component: timeline Version: 0.9.4
Severity: normal Keywords:
Cc: Branch:
Release Notes:
API Changes:

Description

When a ticket has a file added or a comment added the timeline does not update to show a edit has happened.

This is a problem in our project because we are using tickets to track documentation changes (a tracking ticket per document) allowing comments and new version to be posted. The is no clear way of identifying that the ticket has been modified.

Attachments (0)

Change History (5)

comment:1 by Emmanuel Blot, 14 years ago

Resolution: invalid
Status: newclosed

This ticket is two-fold:

  • about timeline update when a comment is added to a ticket, you probably forgot to define
    [timeline]
    ticket_show_details = true
    
    in your trac.ini file
  • about timeline update when a file is attached: this is a duplicate of #2259, which also requests the timeline should be updated when such an event occurs.

comment:2 by anonymous, 17 months ago

Timeline not updated when Tickets are deleted?

in reply to:  2 comment:3 by Ryan J Ollos, 17 months ago

Replying to anonymous:

Timeline not updated when Tickets are deleted?

There is no ticket delete event in the timeline, but all ticket change events should be removed from the timeline for the deleted ticket. If that's not the case for you, please post information about your Trac instance to the MailingList, along with screen captures that demonstrate the issue.

comment:4 by anonymous, 17 months ago

No, that's not the case for me. I think that timeline should include delete history of tickets, ticket comments or any other things in trac. For instance, "ticket 2897 deleted" or "comment 4 in ticket 2897 deleted".

comment:5 by Ryan J Ollos, 17 months ago

See also #6744.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Jonas Borgström.
The resolution will be deleted. Next status will be 'reopened'.
to as closed The owner will be changed from Jonas Borgström to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.