Edgewall Software
Modify

Opened 16 years ago

Closed 16 years ago

Last modified 16 years ago

#2893 closed enhancement (duplicate)

Roadmap View by Component

Reported by: arichards@… Owned by: Christopher Lenz
Priority: low Milestone:
Component: roadmap Version: none
Severity: normal Keywords:
Cc: Branch:
Release Notes:
API Changes:
Internal Changes:

Description

The roadmap view is one of the really good features of trac.

It would be great if an additional roadmap view could be created that used the same type of layout, but instead grouped by component.

This would allow users to review tickets by component, with the handy visual percentage complete indicator and a link to active/closed tickets underneath.

Thank you for considering this request!

Attachments (0)

Change History (8)

comment:1 by anonymous, 16 years ago

Priority: normallow

comment:2 by anonymous, 16 years ago

Resolution: worksforme
Status: newclosed

This is already there on the milestone page.

comment:3 by anonymous, 16 years ago

Resolution: worksforme
Status: closedreopened

I disagree. I don't want it on the milestone page, I want the graphical view with %bars by component, for all components on the same page. I've double checked and I can't see this anywhere.

comment:4 by anonymous, 16 years ago

So you are wanting the per component view on the milestone page(i.e., milestone:0.9.5) also showing on the roadmap page? I personally think that will clutter the roadmap. If you want to see information about a milestone broken down, go to the milestone page. The roadmap should only contain high level information.

comment:5 by Christopher Lenz, 16 years ago

Resolution: worksforme
Status: reopenedclosed

Adding a component breakdown for every milestone on the roadmap page will make the roadmap way too heavy and cluttered.

The milestone page already gives you “the graphical view with %bars by component, for all components on the same page”.

comment:6 by anonymous, 16 years ago

Resolution: worksforme
Status: closedreopened

Sorry to be persistent - perhaps I'm not making myself too clear!

You could consider that the 'TicketStatus by' is perfect, but I want to see that for all milestones. NOT one per milestone (which, I agree, would make it "far too heavy and cluttered"), but one overall by all components.

So what I'm after is a page that shows project status by component not by milestone. It would look just like the existing roadmap, but instead of having one graphical indicator per milestone, you'd have one per component.

I'm not suggesting that you add it to the existing roadmap page, but that you consider adding it as an alternative view on the roadmap page. An enhanced "TicketStatus by" tool would do the trick nicely.

comment:7 by Emmanuel Blot, 16 years ago

Why don't you implement it as a Trac plugin ? You could reuse most of the existing code to implement such a custom view.

comment:8 by Christopher Lenz, 16 years ago

Resolution: duplicate
Status: reopenedclosed

Indeed, that makes this request a duplicate of #740. Meaning that for the time being, such a statistics/dashboard page should be implemented as a plugin. If that plugin turns out to be really useful, we may still consider integrating it directly into Trac.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Christopher Lenz.
The resolution will be deleted. Next status will be 'reopened'.
to The owner will be changed from Christopher Lenz to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.