Edgewall Software
Modify

Opened 14 years ago

Closed 13 years ago

#2882 closed defect (worksforme)

Missing TABLE end tag when viewing a file in Trac browser messes up display

Reported by: anonymous Owned by: Jonas Borgström
Priority: normal Milestone:
Component: version control/browser Version: 0.9.4
Severity: normal Keywords:
Cc: Branch:
Release Notes:
API Changes:

Description

Background

Viewing a file (revision) in the code browser, an HTML preview of the file is generated if possible in templates/browser.cs:

(around line 98)

if:!browser.is_dir ?>
  <div id="preview"><?cs
   if:file.preview ?><?cs

BUG

The problem is that <?cs var:file.preview ?> does not properly end the generated HTML preview with a closing TABLE tag, which messes up the display of the file in a WWW browser such as Firefox or IE.

I don't know where the cause of the error (the "implementation" of the ClearSilver tag var:file.preview above) is located, but I hope this information is sufficient.

EXPECTED

A properly formatted HTML preview of the file is generated.

Workaround

Modify templates/browser.cs at around line 101 as follows:

Change

    var:file.preview ?><?cs

To

    var:file.preview ?></table><?cs

Attachments (0)

Change History (1)

comment:1 by Christian Boos, 13 years ago

Resolution: worksforme
Status: newclosed

I don't know exactly when this was fixed, but it's the TracBrowser (file mode an dir mode) validates on 0.10-stable.

… and with 0.11 this kind of error can't happen anymore ;)

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Jonas Borgström.
The resolution will be deleted. Next status will be 'reopened'.
to as closed The owner will be changed from Jonas Borgström to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.