Edgewall Software
Modify

Opened 17 years ago

Closed 14 years ago

#2803 closed defect (duplicate)

Bad contact detail when an exception is triggered in a plugin

Reported by: Emmanuel Blot Owned by: Jonas Borgström
Priority: lowest Milestone:
Component: general Version: devel
Severity: minor Keywords: plugin setuptools
Cc: Branch:
Release Notes:
API Changes:
Internal Changes:

Description

When an exception is caught by the Trac engine, the exception detail appears on the web page, immediately followed with the following message:

If you think this really should work and you can reproduce it. Then you should consider to report this problem to the Trac team.

Go to http://trac.edgewall.com/ and create a new ticket where you describe the problem, how to reproduce it. Don't forget to include the python traceback found below.

TracGuide — The Trac User and Administration Guide 

This message is not really meaningfull when the fault comes from a plugin. As more and more people are developing and using plugins, the bug tracker for Trac is more likely to receive bug reports that are not related to the core engine.

I think the message should be updated so that it reflects the plugin source of the error, and a nice feature would be to display the contact of the plugin author if it appears in the plugin egg package (author, homepage).

Attachments (0)

Change History (3)

comment:1 by sid, 16 years ago

#3638 was marked as duplicate of this ticket.

comment:2 by Christian Boos, 16 years ago

Keywords: plugin setuptools added
Milestone: 1.0

It would indeed be nice to be able to redirect to the appropriate BTS when a plugin is responsible for the error.

comment:3 by Christian Boos, 14 years ago

Milestone: 1.0
Resolution: duplicate
Status: newclosed

Superseded by #5516.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Jonas Borgström.
The resolution will be deleted. Next status will be 'reopened'.
to The owner will be changed from Jonas Borgström to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.