Edgewall Software
Modify

Opened 16 years ago

Closed 16 years ago

Last modified 16 years ago

#2760 closed defect (duplicate)

rss feed needs unique item ids

Reported by: kaouete@… Owned by: Jonas Borgström
Priority: high Milestone:
Component: timeline Version: 0.9.4
Severity: normal Keywords:
Cc: core@…, kaouete@… Branch:
Release Notes:
API Changes:
Internal Changes:

Description

Hi, rss feeds for timeline doesnt always have unique item ids, it can make a problem with rss reader like liferea, see https://sourceforge.net/tracker/index.php?func=detail&aid=1430189&group_id=87005&atid=581684 for more information about the problem and why it has to be (or not if you dont think so :) fixed in trac.

Attachments (0)

Change History (5)

comment:1 by anonymous, 16 years ago

Milestone: 1.0
Priority: normalhigh
Version: 0.9.30.9.4

The Mozilla Thunderbird 1.5 client seems to miss items too, when the same link was already loaded. This happens with ticket changes where the link doesn't reflect the change number.

so change 1 gives link "..trac/ticket/24", change 2 gives link "..trac/ticket/24" and so on.

For this part, appending the change nr like ..trac/ticket/24#change_1 would help. But maybe there are other problems in uniqueness left..

Would be very nice to have that fixed.

comment:2 by core@…, 16 years ago

Cc: core@… added

comment:3 by anonymous, 16 years ago

Cc: kaouete@… added

comment:4 by Christian Boos, 16 years ago

Milestone: 1.0
Resolution: duplicate
Status: newclosed

Didn't you fix that for 0.10.1, manu?

I think it's a duplicate of #3167.

Plus, the Ticket links now have the #comment:id and the Wiki links have the version number…

in reply to:  4 comment:5 by Emmanuel Blot, 16 years ago

Replying to cboos:

Didn't you fix that for 0.10.1, manu?

Yes. As far as permalink are not required.

I think it's a duplicate of #3167.

I think it is.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Jonas Borgström.
The resolution will be deleted. Next status will be 'reopened'.
to The owner will be changed from Jonas Borgström to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.