Edgewall Software
Modify

Opened 14 years ago

Closed 14 years ago

Last modified 13 years ago

#2739 closed defect (worksforme)

Bug in Trac-Timeline

Reported by: anonymous Owned by: Christian Boos
Priority: high Milestone:
Component: version control Version: 0.9
Severity: major Keywords:
Cc: Branch:
Release Notes:
API Changes:

Description (last modified by Christian Boos)

i haved a project under opencsie.org When i hit "Timeline" in menu, i've this message :

Oops...
Trac detected an internal error:

('No such revision 13', 160006)

If you think this really should work and you can reproduce it. Then you should consider to report this problem to the Trac team.

Go to http://trac.edgewall.com/ and create a new ticket where you describe the problem, how to reproduce it. Don't forget to include the python traceback found below.

TracGuide — The Trac User and Administration Guide
Python traceback

Traceback (most recent call last):
  File "/usr/local/lib/python2.4/site-packages/trac/web/cgi_frontend.py", line 131, in run
    dispatch_request(req.path_info, req, env)
  File "/usr/local/lib/python2.4/site-packages/trac/web/main.py", line 139, in dispatch_request
    dispatcher.dispatch(req)
  File "/usr/local/lib/python2.4/site-packages/trac/web/main.py", line 107, in dispatch
    resp = chosen_handler.process_request(req)
  File "/usr/local/lib/python2.4/site-packages/trac/Timeline.py", line 138, in process_request
    filters)
  File "/usr/local/lib/python2.4/site-packages/trac/versioncontrol/web_ui/changeset.py", line 116, in get_timeline_events
    chgset = repos.get_changeset(rev)
  File "/usr/local/lib/python2.4/site-packages/trac/versioncontrol/cache.py", line 42, in get_changeset
    self.sync()
  File "/usr/local/lib/python2.4/site-packages/trac/versioncontrol/cache.py", line 78, in sync
    changeset = self.repos.get_changeset(current_rev)
  File "/usr/local/lib/python2.4/site-packages/trac/versioncontrol/svn_fs.py", line 252, in get_changeset
    self.fs_ptr, self.pool)
  File "/usr/local/lib/python2.4/site-packages/trac/versioncontrol/svn_fs.py", line 451, in __init__
    message = self._get_prop(core.SVN_PROP_REVISION_LOG)
  File "/usr/local/lib/python2.4/site-packages/trac/versioncontrol/svn_fs.py", line 513, in _get_prop
    return fs.revision_prop(self.fs_ptr, self.rev, name, self.pool())
  File "/usr/local/lib/python2.4/site-packages/libsvn/fs.py", line 575, in svn_fs_revision_prop
    return apply(_fs.svn_fs_revision_prop, args)
SubversionException: ('No such revision 13', 160006)

Attachments (0)

Change History (4)

comment:1 by Christian Boos, 14 years ago

Component: generalversion control
Owner: changed from Jonas Borgström to Christian Boos

Same error as the one reported in #2708. I asked for some more feedback, but got none, so there was no progress on the issue…

  • To what is set your repository_dir in you TracIni?
  • What is the youngest revision in your repository (i.e. svnlook youngest /path/to/repos)?
  • Set the log level to DEBUG and to stderr (see TracLogging), and to a trac-admin <your_trac_env> resync. What's the output?

(I'll close #2708 as a duplicate of this one if I get some feedback here)

comment:2 by anonymous, 14 years ago

i'm not the admin of project but now it's right (after a "tracadmin resync" do by the admin)

comment:3 by Christian Boos, 14 years ago

Resolution: worksforme
Status: newclosed

Ok, so I guess that the check for repository change failed here (see r2312). The only possibility I see is that there was a svn dump + filter + load, and that the UUID of the repository was kept.

comment:4 by Christian Boos, 13 years ago

Description: modified (diff)

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Christian Boos.
The resolution will be deleted. Next status will be 'reopened'.
to as closed The owner will be changed from Christian Boos to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.