Edgewall Software
Modify

Opened 14 years ago

Closed 13 years ago

#2725 closed defect (duplicate)

[PATCH] Ticket changetime is not updated with an attachment

Reported by: Curtis Buys <trac@…> Owned by: Christian Boos
Priority: low Milestone:
Component: ticket system Version: 0.9.3
Severity: minor Keywords: attachment
Cc: trac@… Branch:
Release Notes:
API Changes:
Internal Changes:

Description

The ticket changetime is not updated when a file is attached to a ticket. The "last modified" field is either not displayed or show's an incorrect time further in the past than when the ticket really was modified.

Patch forthcoming.

Attachments (1)

update_ticket_changetime_with_attachment.patch (764 bytes ) - added by Curtis Buys <trac@…> 14 years ago.

Download all attachments as: .zip

Change History (7)

by Curtis Buys <trac@…>, 14 years ago

comment:1 by Curtis Buys <trac@…>, 14 years ago

Cc: trac@… added
Summary: Ticket changetime is not updated with an attachment[PATCH] Ticket changetime is not updated with an attachment

comment:2 by anonymous, 14 years ago

Milestone: 0.11

Adding a milestone so this gets attention.

comment:3 by anonymous, 14 years ago

This ticket is similar to #1278 (attaching files to wiki pages does not update last changed date) and #2259 (No notification email when adding an attachment to a ticket).

comment:4 by Christian Boos, 14 years ago

Keywords: review removed
Owner: changed from Jonas Borgström to Christian Boos

Yeah, all this issues will probably benefit from an unified change notification mechanism. This is somehow related to the TracDev/Proposals/Journal, but the API can change first, then the underlying data model.

comment:5 by Christian Boos, 13 years ago

Keywords: attachment added
Milestone: 0.111.0

Attachments should be reworked so that they can be "versioned" and attachment related changes would be "persistent".

comment:6 by Christian Boos, 13 years ago

Milestone: 1.0
Resolution: duplicate
Status: newclosed

Actually, this can be seen as a duplicate of #1278.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Christian Boos.
The resolution will be deleted. Next status will be 'reopened'.
to The owner will be changed from Christian Boos to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.