Edgewall Software
Modify

Opened 16 years ago

Closed 16 years ago

#2681 closed defect (worksforme)

File download revision (in URL) is not equal to expected

Reported by: Dan <trac@…> Owned by: Jonas Borgström
Priority: normal Milestone:
Component: version control/browser Version: 0.9.3
Severity: normal Keywords:
Cc: Branch:
Release Notes:
API Changes:
Internal Changes:

Description

Scenario:

  1. I was viewing a subdirectory in a tag. The tag was made in changeset 772.
  2. I was interested in a "large" (non-viewable) file that had been updated in changeset 771. Clicked on "771" in the "Rev" column.
  3. The log information appeared, with lines for changesets 771 and 772.
  4. Clicked on "@772" in the "Rev" column.
  5. Clicked on the "download" link, but that link includes the following: "?rev=771".
  6. Received an error message there is "No node at ...", of course, because the revision should actually be 772.

Modifying the "download" URL to 772 allows downloading the file.

This behavior does not seem to affect a file that is small enough to view. That is, the file is viewed properly. In this case, I also noticed that the "original format" link does not contain any "?rev=" portion.

Platform: Subversion 1.3.0 with 1.2.3 Pythyon bindings, Python 2.4.2, Windows x64.

Attachments (0)

Change History (1)

comment:1 by Christian Boos, 16 years ago

Resolution: worksforme
Status: newclosed

I was able to reproduce this using the milestone:0.9.2 code base and doing a resync.

As you already have milestone:0.9.3, which has the fix for this problem, simply do a resync and try again, everything should now work as you'd expect.

If not, feel free to reopen the ticket.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Jonas Borgström.
The resolution will be deleted. Next status will be 'reopened'.
to The owner will be changed from Jonas Borgström to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.