Edgewall Software
Modify

Opened 15 years ago

Closed 15 years ago

Last modified 14 years ago

#2599 closed defect (duplicate)

can't import a repo with a copied-from-before-then-modified state

Reported by: radix@… Owned by: Jonas Borgström
Priority: normal Milestone:
Component: general Version: 0.9.2
Severity: normal Keywords:
Cc: Branch:
Release Notes:
API Changes:
Internal Changes:

Description

A repository that's had the following done:

  foo/bar/ exists at revN
  svn rm foo; svn commit
  svn cp -r 1 svn://../foo foo
  svn propset svn:ignore 'blargh' foo/bar
  svn commit

can't be imported by trac. A tar file containing a dump of such a repository and the actual command-history leading up to it is at http://twistedmatrix.com/users/exarkun/initenv-bug.tar

The error that it shows is something like:

 Indexing repository
Failed to initialize environment. ("File not found: revision 2, path '/foo/bar'", 160013)
Traceback (most recent call last):
  File "/home/trac/usr/lib/python2.4/site-packages/trac/scripts/admin.py", line 617, in do_initenv
    repos.sync()
  File "/home/trac/usr/lib/python2.4/site-packages/trac/versioncontrol/cache.py", line 83, in sync
    for path,kind,action,base_path,base_rev in changeset.get_changes():
  File "/home/trac/usr/lib/python2.4/site-packages/trac/versioncontrol/svn_fs.py", line 488, in get_changes
    change.base_path, pool())
SubversionException: ("File not found: revision 2, path '/foo/bar'", 160013)

This problem showed itself when trying to import the Twisted repository.

Attachments (0)

Change History (3)

comment:1 by Mark Rowe, 15 years ago

This appears to work correctly with r2763. It's not obvious to me which changeset is responsible for fixing the problem, but if someone can track it down I think it would be a candidate for being included in a future 0.9.x release (should one happen).

comment:2 by Mark Rowe, 15 years ago

alect pointed out that the fix is likely [2623].

comment:3 by Christian Boos, 15 years ago

Resolution: duplicate
Status: newclosed

Yes, I confirm the bug is present in 0.9.2 but not in 0.9.3 anymore. Please upgrade.

Also, if you have a very big repository, you might even want the fix for a resync memory leak that is in 0.9.4pre (svn co http://svn.edgewall.com/repos/trac/branches/0.9-stable)

Duplicate of #2440.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Jonas Borgström.
The resolution will be deleted. Next status will be 'reopened'.
to The owner will be changed from Jonas Borgström to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.