Edgewall Software
Modify

Opened 14 years ago

Closed 13 years ago

#2406 closed enhancement (duplicate)

"Add another attachment" button

Reported by: mrenzmann@… Owned by: Jonas Borgström
Priority: low Milestone:
Component: ticket system Version: 0.9b2
Severity: minor Keywords: needinfo
Cc: pkou@… Branch:
Release Notes:
API Changes:

Description

After attaching a file to a ticket the newly created attachment is shown. For adding another attachment one has to click on the ticket number in the preview title, scroll down and press the the "Add attachment" button again.

It would be nice if there was another solution. Two possibilities come to my mind:

  1. Show a "Add another attachment" button in the attachment view right after the file has been attached. Of course this button shouldn't be visible when someone else views the attachment at a later time.
  2. Add a "Add another attachment" option to the "add attachment" page. If this option is selected Trac doesn't show the fresh attachment but brings up the "Add attachment" page again.

I think this would add a little to the usability of Trac.

Attachments (0)

Change History (5)

comment:1 by anonymous, 14 years ago

Cc: pkou@… added

comment:2 by Christian Boos, 13 years ago

Keywords: needinfo added

Most browser have a Back button those days, right?

I'd suggest a wontfix on this one. Any other (motivated) opinion?

comment:3 by sid, 13 years ago

Probably a duplicate of #2141, although that also has the idea of deleting multiple attachments at the same time.

in reply to:  2 comment:4 by Emmanuel Blot, 13 years ago

Replying to cboos:

Most browser have a Back button those days, right? I'd suggest a wontfix on this one. Any other (motivated) opinion?

I think it is fair to close it as wontfix (plus, the back button provides a nice side effect: it preserves the comments).

Nevertheless, I think the RSS property should be tweaked so that the ticket number or the wiki page name that stands as the page header appears with the same color as a regular ticket or wiki link, which would make the link back to the original page more obvious.

in reply to:  3 comment:5 by Matthew Good, 13 years ago

Resolution: duplicate
Status: newclosed

Replying to sid:

Probably a duplicate of #2141, although that also has the idea of deleting multiple attachments at the same time.

Yeah, I think #2141 addresses basically the same issue.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Jonas Borgström.
The resolution will be deleted. Next status will be 'reopened'.
to as closed The owner will be changed from Jonas Borgström to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.