Edgewall Software
Modify

Opened 15 years ago

Closed 15 years ago

#2376 closed defect (duplicate)

unable to authenticate with apache

Reported by: cpanelapache@… Owned by: Jonas Borgström
Priority: normal Milestone:
Component: general Version: 0.9
Severity: normal Keywords:
Cc: Branch:
Release Notes:
API Changes:
Internal Changes:

Description (last modified by Emmanuel Blot)

Hey im using trac 0.9 with apache 2 and currently im unable to get it to offer authentication for the /login the error i get from trac is this

No handler matched request to /error/HTTP_UNAUTHORIZED.html.var

my virtual host configuration looks like this

<VirtualHost *>
    DocumentRoot C:/wiki/cpanelapache
    ServerName wiki.lvlymatt.uni.cc

    <Directory />
        SetHandler mod_python
        PythonHandler trac.web.modpython_frontend
        PythonOption TracEnv C:/wiki/cpanelapache
        PythonOption TracUriRoot /
    </Directory>  

    <Location "/login">
        AuthType Basic
        AuthName "Developers wiki login"
        AuthUserFile "C:/etc/wiki"
        Require valid-user
    </Location>
</VirtualHost>

Attachments (0)

Change History (4)

comment:1 by Emmanuel Blot, 15 years ago

Description: modified (diff)
Priority: highnormal
Summary: unbale to authenticate with apacheunable to authenticate with apache

(fixing description and summary)

I think you may ask for help on the mailing list first, as it seems to be a configuration issue.

comment:2 by cpanelapache@…, 15 years ago

Resolution: fixed
Status: newclosed

Thanks already found a solution the work around was to add ErrorDocument 401 default inside the virtualhost container.

comment:3 by Matthew Good, 15 years ago

Resolution: fixed
Status: closedreopened

Please only used the "fixed" resolution for issues that required a code change to resolve.

comment:4 by Matthew Good, 15 years ago

Resolution: duplicate
Status: reopenedclosed

This is a duplicate of #2371.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Jonas Borgström.
The resolution will be deleted. Next status will be 'reopened'.
to The owner will be changed from Jonas Borgström to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.