Edgewall Software
Modify

Opened 15 years ago

Closed 15 years ago

#2347 closed defect (duplicate)

attach file function failed

Reported by: laurent.querel@… Owned by: Jonas Borgström
Priority: normal Milestone:
Component: general Version: 0.9
Severity: major Keywords:
Cc: Branch:
Release Notes:
API Changes:
Internal Changes:

Description (last modified by Christian Boos)

Trac version 0.9 (windows)

1 - Clik on "Attach File" Button 2 - Select a file (for my test file size = 3.6Mb) 3 - Save 4 - Crash

Trac detected an internal error: 
'StringField' object has no attribute 'filename'
 
Python traceback
Traceback (most recent call last):
  File "C:\Python23\Lib\site-packages\trac\web\modpython_frontend.py", line 206, in handler
    dispatch_request(mpr.path_info, mpr, env)
  File "C:\Python23\Lib\site-packages\trac\web\main.py", line 139, in dispatch_request
    dispatcher.dispatch(req)
  File "C:\Python23\Lib\site-packages\trac\web\main.py", line 107, in dispatch
    resp = chosen_handler.process_request(req)
  File "C:\Python23\Lib\site-packages\trac\attachment.py", line 265, in process_request
    self._do_save(req, attachment)
  File "C:\Python23\Lib\site-packages\trac\attachment.py", line 296, in _do_save
    if not upload.filename:
AttributeError: 'StringField' object has no attribute 'filename'

Attachments (0)

Change History (1)

comment:1 by Christian Boos, 15 years ago

Description: modified (diff)
Resolution: duplicate
Status: newclosed

Duplicate of #554. See TracModPython#Win32Issues for a solution to this known issue.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Jonas Borgström.
The resolution will be deleted. Next status will be 'reopened'.
to The owner will be changed from Jonas Borgström to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.