Edgewall Software
Modify

Opened 14 years ago

Closed 13 years ago

#2342 closed defect (worksforme)

Tracd stops working

Reported by: mischa@… Owned by: Jonas Borgström
Priority: normal Milestone:
Component: web frontend/tracd Version: 0.9
Severity: blocker Keywords:
Cc: Branch:
Release Notes:
API Changes:

Description

After clicking on either "Timeline" or "Browse Source" tracd stops serving pages. The process is still running, but no data is send back to the browser.

FreeBSD 5.4 Subversion 1.3.0r2 Python 2.4.2 Swig 1.3.27

Truss trace is available.

Attachments (1)

tracd.trace (233.7 KB ) - added by mischa@… 14 years ago.
Tracd trace with truss

Download all attachments as: .zip

Change History (2)

by mischa@…, 14 years ago

Attachment: tracd.trace added

Tracd trace with truss

comment:1 by Christian Boos, 13 years ago

Resolution: worksforme
Status: newclosed

AFAICT, Swig 1.3.27 isn't supported for building the Python bindings for Subversion 1.3.0: only 1.3.24 or 1.3.25 should be used. Anyway the latest 1.3.0 distributions contained the generated code, I don't know if that was the case for rc2 though.

Please reopen if the issue is still there with the latest 1.3.0 release

(also, the tracd.trace is useless as it stops with the parent process doing a fork(), i.e. when things should only begin to be interesting! Don't know if there's a kind of follow fork option to truss, but if so, you should use that the next time).

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Jonas Borgström.
The resolution will be deleted.
to The owner will be changed from Jonas Borgström to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.