Edgewall Software
Modify

Opened 14 years ago

Closed 13 years ago

#2139 closed defect (duplicate)

fcgi output inconsistency

Reported by: kevin Owned by: Jonas Borgström
Priority: normal Milestone:
Component: general Version: 0.9.5
Severity: normal Keywords:
Cc: Branch:
Release Notes:
API Changes:

Description

When I switch from trac.cgi to trac.fcgi Trac appears to get very unstable. The app works but I get quite a few instances where I click on a link and get a trac/python traceback on the browser rather than the content. Usually clicking 'back' and repeating the action results in the correct response.

Attachments (2)

trac_dump1.txt (5.7 KB ) - added by kevin 14 years ago.
The results of clicking on 'Wiki'
trac_error2.txt (7.9 KB ) - added by kevin 14 years ago.
Output from trac (0.9) after clicking 'New Ticket'

Download all attachments as: .zip

Change History (8)

by kevin, 14 years ago

Attachment: trac_dump1.txt added

The results of clicking on 'Wiki'

comment:1 by georg, 14 years ago

same happens on my gentoo system with trac 0.9

comment:2 by kevin, 14 years ago

This is still an issue with 0.9

See new attachment.

by kevin, 14 years ago

Attachment: trac_error2.txt added

Output from trac (0.9) after clicking 'New Ticket'

comment:3 by Matthew Good, 14 years ago

Resolution: duplicate
Status: newclosed

I think that this is basically the same issue as #2252.

comment:4 by thomas.jachmann, 14 years ago

I don't think this is a duplicate since the stack trace mentions completely different sections in the code and #2252 doesn't result in errors going back to the browser. They only appear in apache's error log, the browser displays the correct pages.

comment:5 by rachel@…, 13 years ago

Resolution: duplicate
Status: closedreopened
Version: 0.9b20.9.5

I am seeing this error with Trac 0.9.5 when I run it under fcgid. When I run it with fastcgi, I get the error described in ticket:2252. In both cases I'm using Apache 2.0.54 on CentOS 4.3. In both cases the errors are intermittent and come about every 5-10 page views. I chose to use fastcgi and reduce the timeout value as that provides us with the least annoyance, but neither is really satisfactory.

I am reopening this ticket to flag it, in case this information makes either or both of these behaviors reproducible for anyone at Edgewall. I will be happy to post log files or provide any further info that you may ask for. I haven't heard of this issue on either fcgid or fastcgi in any app other than trac which makes me think it may be trac-related after all. When I have a moment I will install trac 0.9.6 and see if these errors still occur.

comment:6 by Matthew Good, 13 years ago

Resolution: duplicate
Status: reopenedclosed

It appears this is actually a duplicate of #2783 which has been fixed for 0.10.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Jonas Borgström.
The resolution will be deleted. Next status will be 'reopened'.
to as closed The owner will be changed from Jonas Borgström to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.