Edgewall Software
Modify

Opened 14 years ago

Closed 11 years ago

#1948 closed task (invalid)

webadmin plugin giving template error

Reported by: brad <brad@…> Owned by: Christopher Lenz
Priority: lowest Milestone:
Component: web frontend Version: 0.10-stable
Severity: trivial Keywords: webadmin
Cc: Baeza Branch:
Release Notes:
API Changes:

Description

I'm not sure what I'm doing wrong here w/ the setup, but the webadmin plugin used to work. Now when I click on Admin, I get this:

Traceback (most recent call last):
  File "/usr/lib/python2.3/site-packages/trac/web/modpython_frontend.py", line 210, in handler
    dispatch_request(mpr.path_info, mpr, env)
  File "/usr/lib/python2.3/site-packages/trac/web/main.py", line 144, in dispatch_request
    dispatcher.dispatch(req)
  File "/usr/lib/python2.3/site-packages/trac/web/main.py", line 118, in dispatch
    req.display(template, content_type or 'text/html')
  File "/usr/lib/python2.3/site-packages/trac/web/api.py", line 153, in display
    data = self.hdf.render(template)
  File "/usr/lib/python2.3/site-packages/trac/web/clearsilver.py", line 260, in render
    template.parseFile(filename)
Error: Traceback (innermost last):
  File "csparse.c", line 293, in cs_parse_file()
  File "neo_hdf.c", line 1896, in hdf_search_path()
NotFoundError: Path admin.cs not found

I'm using mod_python, and trunk & webadmin plugin are current (r2098) - I'm installing the egg globally.

Attachments (0)

Change History (4)

comment:1 by brad <brad@…>, 14 years ago

Resolution: invalid
Status: newclosed

Sorry, I had another egg full of plugins that was conflicting with the webadmin.

comment:2 by Martin Burger <mburger@…>, 13 years ago

How did you resolve that problem?

comment:3 by Alex Baeza, 11 years ago

Cc: Baeza added
Component: web frontend/mod_pythonweb frontend
Priority: normallowest
Resolution: invalid
Severity: normaltrivial
Status: closedreopened
Type: defecttask
Version: devel0.10-stable

I am having the same issue, and WebAdmin is my very first plugin, so i don't think any other plugins are conflicting. Please help! I am using Trac 0.10.4 I have built the latest admin from svn TracWebAdmin-0.1.2dev-py2.4.egg and placed it in my project's plugins directory. I am using Apache and fast cgi.

However when I attempt to access it i get the same error described above.

I assume I am doing something wrong and that this is not a bug, but would appreciate any help you can provide.

comment:4 by ebray, 11 years ago

Resolution: invalid
Status: reopenedclosed

This is an installation question that should be asked on the MailingList or IrcChannel. Please don't reopen tickets that have already been resolved as being non-issues.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Christopher Lenz.
The resolution will be deleted. Next status will be 'reopened'.
to as closed The owner will be changed from Christopher Lenz to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.