Edgewall Software
Modify

Opened 15 years ago

Closed 15 years ago

Last modified 15 years ago

#1767 closed defect (duplicate)

Wrong format of RSS feed before authentification

Reported by: Alexander Shopov Owned by: Jonas Borgström
Priority: low Milestone:
Component: general Version: 0.8.4
Severity: minor Keywords:
Cc: ash@… Branch:
Release Notes:
API Changes:
Internal Changes:

Description

We have an internal uptodate installation of trac 0.8.4 on Apache with mod_python. We have configured it to use authetification - the anonymous user cannot reach any resources - it is not listed in

list permissions

at all. When a person that has not authenticated tries ot use a RSS to read some part of trac, what trac generates back is the initial login page which is not in RSS feed format.

I would suggest generating a page similar in content to the login page that says more or less You are not authenticated, go here <link> in RSS format (maybe changing the RSS feed title to "Origirnal title + Not authenticated" or sth. similar). This way feeds will not be presumed to be broken by a RSS feed reader.

Best regards:

al_shopov

Attachments (0)

Change History (2)

comment:1 by Christopher Lenz, 15 years ago

Milestone: 0.9
Resolution: duplicate
Status: newclosed

Hmm, if anonymous isn't allowed to read any part of your Trac install, then you should have protected the entire site, which would trigger HTTP authentication. This doesn't involve a "login page" – in fact there is no such page in Trac.

Anyway, I think this can be considered a duplicate of #540.

comment:2 by ash@…, 15 years ago

Yep, This is a duplicate of #540. When I said "login page" I meant the page that gives you chance to login or create a new session. (The page below the line)


Error accessing authenticated session

Session cookie requires authentication.

Please choose action:

  • Log in and continue session
  • Create new session (no login required)

TracGuide — The Trac User and Administration Guide

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Jonas Borgström.
The resolution will be deleted. Next status will be 'reopened'.
to The owner will be changed from Jonas Borgström to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.