Edgewall Software
Modify

Opened 14 years ago

Closed 14 years ago

Last modified 14 years ago

#1750 closed defect (fixed)

WikiSystem object instanciation and holding page names

Reported by: Shun-ichi Goto <gotoh@…> Owned by: Christopher Lenz
Priority: high Milestone: 0.9
Component: wiki system Version: devel
Severity: major Keywords:
Cc: Branch:
Release Notes:
API Changes:

Description

On using multi project, WikiSystem class object in trac/wiki/api.py fetch the page names in the project from db only when instanciation. Because the object holds them within other project, as result, wiki page links are rendered as missed page although the page is actually exist.

Attachments (0)

Change History (5)

comment:1 by Christopher Lenz, 14 years ago

Milestone: 0.9
Owner: changed from Jonas Borgström to Christopher Lenz
Priority: normalhigh
Severity: normalmajor
Status: newassigned

Actually, the problem is that notifications about added/removed pages only happen in a single process/interpreter, which is a problem when running under mod_python.

comment:2 by Christian Boos, 14 years ago

Maybe, but there's anyway a problem here, even in the single process case: the link resolvers are stored in a Formatter class attributes (Formatter._link_resolvers), therefore tying a specific environment to the Formatter, which is not something one wants to do in a multi-environment setup.

I'm currently fixing that in the InterTrac branch.

comment:3 by Christopher Lenz, 14 years ago

Resolution: fixed
Status: assignedclosed

Fixed in [1977].

(cboos: that's a different issue then. If you have a fix, please apply it to trunk, too.)

comment:4 by Shun-ichi Goto <gotoh@…>, 14 years ago

[1977] does not fix this issue, but [1979] does. Now the page lines are rendered correctly on mod_python multi-project environment.

comment:5 by Christopher Lenz, 14 years ago

Yeah, [1977] is the fix for a single-project setup, [1979] for multi-project. The latter fixes the issue cboos raises above.

Thanks for verifying.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Christopher Lenz.
The resolution will be deleted. Next status will be 'reopened'.
to as closed The owner will be changed from Christopher Lenz to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.