Edgewall Software
Modify

Opened 16 years ago

Closed 16 years ago

Last modified 15 years ago

#1747 closed defect (worksforme)

trac-admin very sloppy in assigning permissions in db

Reported by: treed@… Owned by: Jonas Borgström
Priority: normal Milestone:
Component: general Version: 0.8.4
Severity: normal Keywords:
Cc: treed@… Branch:
Release Notes:
API Changes:
Internal Changes:

Description

While experimenting with trac permissions I tried a number of combinations of specifying permissions to trac-admin and I ended up with things like "user","action," with an extra comma on the end as well as "user","action1,action2,action3" as well as user with an action each on a separate row. I suspect that trac-admin should probably be much more consistant in how it inserts permissions into the database.

Attachments (0)

Change History (2)

comment:1 by Rede, 16 years ago

If would have read syntax of permission add - command in TracAdmin page, you would have noticed that it doesn't contain comma in syntax anywhere.

So being mean - it was you who was sloppy (or made wrong assumption) not trac-admin. :)

Trac-admin is very consistent - it uses only spaces to separate things.

comment:2 by Rede, 16 years ago

Resolution: worksforme
Status: newclosed

As this seems to be working as intended closing ticket. If this still an issue provide more information and reopen ticket. Example of "expected results" and "actual results" would help a lot resolving issue properly.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Jonas Borgström.
The resolution will be deleted. Next status will be 'reopened'.
to The owner will be changed from Jonas Borgström to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.