Edgewall Software
Modify

Opened 14 years ago

Closed 14 years ago

Last modified 11 years ago

#1625 closed defect (duplicate)

wrong charset encoding in from svn commit message

Reported by: szaman@… Owned by: Jonas Borgström
Priority: high Milestone:
Component: ticket system Version: 0.8.4
Severity: major Keywords: utf-8 unicode
Cc: szaman@…, m@… Branch:
Release Notes:
API Changes:

Description

When i commit into svn repo using utf-8 chars, i see strange things/chars in:

  • ticket view (changelog)
  • timeline (only in tickets)

For example: "co?\197?\155 si?\196?\153" should be "coś się".

Other components seems to be ok.

I use debian-sarge trac package (v. 0.8.1-3).

Example screenshot in attachment.

Attachments (1)

trac.encoding.bug.png (8.9 KB ) - added by szaman 14 years ago.
forgotten? screenshot

Download all attachments as: .zip

Change History (6)

by szaman, 14 years ago

Attachment: trac.encoding.bug.png added

forgotten? screenshot

comment:1 by szaman@…, 14 years ago

Version: 0.8.10.8.4

In debian trac-0.8.4-1 behaves the same way…

comment:2 by Markus Tacker <m@…>, 14 years ago

Cc: m@… added
Keywords: utf-8 added

comment:3 by Markus Tacker <m@…>, 14 years ago

Keywords: unicode added

comment:4 by Markus Tacker <m@…>, 14 years ago

This also affects the changeset view: http://meine-jugend.net/trac/jugend/changeset/49

comment:5 by szaman, 14 years ago

Resolution: duplicate
Status: newclosed

Duplicate of #1310

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Jonas Borgström.
The resolution will be deleted. Next status will be 'reopened'.
to as closed The owner will be changed from Jonas Borgström to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.