Edgewall Software
Modify

Opened 14 years ago

Closed 14 years ago

Last modified 13 years ago

#1618 closed defect (fixed)

reStructuredText doesn't work with docutils 0.3.10

Reported by: dserodio@… Owned by: Christopher Lenz
Priority: normal Milestone: 0.8.2
Component: general Version: 0.8.1
Severity: normal Keywords:
Cc: Branch:
Release Notes:
API Changes:

Description

I didn't have docutils installed, so I went to their site and downloaded the "lastest version". This version is labelled as 0.3.10, and causes whe following error (e.g., on WikiRestructuredText):

Docutils version >= 0.3.3 required, 0.3.10 found

This is caused by the fact that the version numbers are compared as strings. The attached patch fixes this by using distutils.version.LooseVersion for comparing version numbers.

I'm setting the milestone to 0.8.2 because it's a really simple patch, localized to reStructuredText support, and I don't think it could introduce buggy side-effects, but feel free to re-schedule it.

Attachments (1)

rst.py.patch (671 bytes ) - added by dserodio@… 14 years ago.
Patch against 1458

Download all attachments as: .zip

Change History (3)

by dserodio@…, 14 years ago

Attachment: rst.py.patch added

Patch against 1458

comment:1 by Christopher Lenz, 14 years ago

Owner: changed from Jonas Borgström to Christopher Lenz
Status: newassigned

Okay, I'll slip this fix into 0.8.2.

comment:2 by Christopher Lenz, 14 years ago

Resolution: fixed
Status: assignedclosed

Fixed in [1748] (trunk) and [1749] (stable branch). Thanks!

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Christopher Lenz.
The resolution will be deleted. Next status will be 'reopened'.
to as closed The owner will be changed from Christopher Lenz to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.