Edgewall Software
Modify

Opened 17 years ago

Closed 17 years ago

#1470 closed enhancement (duplicate)

using a default page for new wiki page

Reported by: sn00py.2@… Owned by: Jonas Borgström
Priority: normal Milestone:
Component: wiki system Version: 0.8.1
Severity: normal Keywords:
Cc: Branch:
Release Notes:
API Changes:
Internal Changes:

Description

Hi,

I need to customize the wiki text displayed by trac when someone create a new page in order to force him to use a skeleton for his page. (for example, I'm using a macro who display a menu like in TracGuide)

I've made a small patch to Wiki.py who allow to create a page named 'defaultPage' displayed when someone create a new page. This page is displayed only if user have write permission, maybe an other one could be used to display a 'not found' error.

Look attachment for the diff.

Attachments (1)

Wiki.py.diff (813 bytes ) - added by sn00py.2@… 17 years ago.
patch to customize new page

Download all attachments as: .zip

Change History (2)

by sn00py.2@…, 17 years ago

Attachment: Wiki.py.diff added

patch to customize new page

comment:1 by Christopher Lenz, 17 years ago

Resolution: duplicate
Status: newclosed

This is actually a duplicate of #962.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Jonas Borgström.
The resolution will be deleted. Next status will be 'reopened'.
to The owner will be changed from Jonas Borgström to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.