Edgewall Software
Modify

Opened 16 years ago

Closed 16 years ago

#1405 closed defect (duplicate)

trac should redirect automatically to login page when non-authenticated

Reported by: aadis Owned by: Jonas Borgström
Priority: normal Milestone:
Component: general Version: 0.8.1
Severity: normal Keywords:
Cc: Branch:
Release Notes:
API Changes:
Internal Changes:

Description

When my session is not authenticated, trac displays an error page rather than directly sending me to the login page.

This ensures RSS readers fail to read my authenticated feed as they never get the authentication challenge, and cannot prompt me for login/password.

I'm using https and http basic authentication along with mod_python on Debian Sarge.

Attachments (0)

Change History (1)

comment:1 by Matthew Good, 16 years ago

Resolution: duplicate
Status: newclosed

This is a duplicate of #540

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Jonas Borgström.
The resolution will be deleted. Next status will be 'reopened'.
to The owner will be changed from Jonas Borgström to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.