Edgewall Software
Modify

Opened 3 months ago

Closed 3 months ago

Last modified 3 months ago

#13496 closed defect (duplicate)

Uploading an attachment fails with "AssertionError: write() before start_response()"

Reported by: anonymous Owned by:
Priority: normal Milestone:
Component: web frontend Version:
Severity: major Keywords:
Cc: Branch:
Release Notes:
API Changes:
Internal Changes:

Description

When adding an attachment to a wiki page (or just clicking the cancel button on the Add Attachment page) I get the error below in the browser (and in the Apache error log). No attachment is saved or added to the wiki page.

Trac version: 1.5.4dev from the trunk at revision 17603

OS: Fedora Server 34

Python version: 3.9.4

Traceback (most recent call last):
  File "/usr/local/lib/python3.9/site-packages/trac/web/_fcgi.py", line 572, in run
    protocolStatus, appStatus = self.server.handler(self)
  File "/usr/local/lib/python3.9/site-packages/trac/web/_fcgi.py", line 1250, in handler
    write(b'') # in case body was empty
  File "/usr/local/lib/python3.9/site-packages/trac/web/_fcgi.py", line 1203, in write
    assert headers_set, 'write() before start_response()'
AssertionError: write() before start_response()

Attachments (0)

Change History (2)

comment:1 by Jun Omae, 3 months ago

Component: attachmentweb frontend
Keywords: attachment wiki removed
Resolution: duplicate
Status: newclosed

Thanks for the reporting. That is a duplicate of #13492 and has been fixed in trunk (r17604).

in reply to:  1 comment:2 by anonymous, 3 months ago

Confirmed fixed. Thank you.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The ticket will remain with no owner.
The resolution will be deleted. Next status will be 'reopened'.
to The owner will be changed from (none) to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.