Edgewall Software
Modify

Opened 3 months ago

Closed 3 months ago

#13489 closed defect (duplicate)

OperationalError: ambiguous column name: id

Reported by: admin Owned by:
Priority: normal Milestone:
Component: query system Version:
Severity: normal Keywords:
Cc: Branch:
Release Notes:
API Changes:
Internal Changes:

Description

How to Reproduce

While doing a GET operation on /query, Trac issued an internal error.

(please provide additional details here)

Request parameters:

{u'col': [u'id',
          u'summary',
          u'type',
          u'owner',
          u'doc_title',
          u'doc_revision',
          u'doc_revdate',
          u'doc_tag',
          u'doc_author',
          u'doc_reviewer',
          u'doc_approver'],
 u'group': u'status',
 u'order': u'priority',
 u'report': u'21',
 u'summary': u'~FSA101',
 u'type': [u'Document', u'WindchillDocument']}

User agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.15; rv:103.0) Gecko/20100101 Firefox/103.0

System Information

Trac 1.2.3
Babel 1.3
Docutils 0.12
Genshi 0.7 (with speedups)
Pygments 2.1
pysqlite 2.6.0
Python 2.7.9 (default, Apr 2 2015, 15:33:21)
[GCC 4.9.2]
pytz 2014.10
setuptools 18.0.1
SQLite 3.11.0
Subversion 1.9.3 (r1718519)
jQuery 1.11.3
jQuery UI 1.11.4
jQuery Timepicker 1.5.5

Enabled Plugins

ExcelDownloadPlugin 0.12.0.6
KeepInterfaceSimple2Plugin 2.5
MultipleWorkflowPlugin 1.4.1
TicketImport 0.9.0
Tracchildtickets 2.5.6.dev0
TracCustomFieldAdmin 0.2.12
TracMasterTickets 4.0.2
TracMathJax 0.4
TracSQL 0.3
TracWysiwyg 0.12.0.7
WikiTableMacro 0.3.dev0

Interface Customization

shared-htdocs
shared-templates
site-htdocs Andar_logo_320_132.png, logo.png
site-templates site.html

Python Traceback

Traceback (most recent call last):
  File "build/bdist.linux-x86_64/egg/trac/web/main.py", line 647, in _dispatch_request
    dispatcher.dispatch(req)
  File "build/bdist.linux-x86_64/egg/trac/web/main.py", line 248, in dispatch
    resp = chosen_handler.process_request(req)
  File "build/bdist.linux-x86_64/egg/trac/ticket/query.py", line 1016, in process_request
    return self.display_html(req, query)
  File "build/bdist.linux-x86_64/egg/trac/ticket/query.py", line 1122, in display_html
    tickets = query.execute(req, cached_ids=orig_list)
  File "build/bdist.linux-x86_64/egg/trac/ticket/query.py", line 303, in execute
    self.num_items = self._count(sql, args)
  File "build/bdist.linux-x86_64/egg/trac/ticket/query.py", line 284, in _count
    % sql, args)[0][0]
  File "build/bdist.linux-x86_64/egg/trac/db/api.py", line 122, in execute
    return db.execute(query, params)
  File "build/bdist.linux-x86_64/egg/trac/db/util.py", line 128, in execute
    cursor.execute(query, params if params is not None else [])
  File "build/bdist.linux-x86_64/egg/trac/db/util.py", line 72, in execute
    return self.cursor.execute(sql_escape_percent(sql), args)
  File "build/bdist.linux-x86_64/egg/trac/db/sqlite_backend.py", line 88, in execute
    result = PyFormatCursor.execute(self, *args)
  File "build/bdist.linux-x86_64/egg/trac/db/sqlite_backend.py", line 64, in execute
    args or [])
  File "build/bdist.linux-x86_64/egg/trac/db/sqlite_backend.py", line 55, in _rollback_on_error
    return function(self, *args, **kwargs)
OperationalError: ambiguous column name: id

Attachments (0)

Change History (1)

comment:1 by Jun Omae, 3 months ago

Component: generalquery system
Resolution: duplicate
Status: newclosed

Duplicate of #13068.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The ticket will remain with no owner.
The resolution will be deleted. Next status will be 'reopened'.
to The owner will be changed from (none) to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.