Edgewall Software
Modify

Opened 2 months ago

Closed 2 months ago

Last modified 2 months ago

#13421 closed defect (duplicate)

ImportError: cannot import name 'soft_unicode' from 'jinja2.utils'

Reported by: Tomasz Brzezina <tomasz@…> Owned by:
Priority: normal Milestone:
Component: general Version:
Severity: normal Keywords:
Cc: Branch:
Release Notes:
API Changes:
Internal Changes:

Description (last modified by Jun Omae)

I installed https://download.edgewall.org/trac/Trac-1.5.3.tar.gz (BTW there's no Trac-latest.zip which is mentioned here 1.5/TracInstall)

After installation trac-admin result is:

Traceback (most recent call last):
  File "/usr/local/bin/trac-admin", line 5, in <module>
    from trac.admin.console import run
  File "/usr/local/lib/python3.9/dist-packages/trac/admin/console.py", line 34, in <module>
    from trac.env import Environment
  File "/usr/local/lib/python3.9/dist-packages/trac/env.py", line 52, in <module>
    from trac.web.chrome import Chrome
  File "/usr/local/lib/python3.9/dist-packages/trac/web/chrome.py", line 40, in <module>
    from trac.mimeview.api import RenderingContext, get_mimetype
  File "/usr/local/lib/python3.9/dist-packages/trac/mimeview/__init__.py", line 14, in <module>
    from trac.mimeview.api import *
  File "/usr/local/lib/python3.9/dist-packages/trac/mimeview/api.py", line 70, in <module>
    from trac.resource import Resource
  File "/usr/local/lib/python3.9/dist-packages/trac/resource.py", line 21, in <module>
    from trac.util.presentation import classes
  File "/usr/local/lib/python3.9/dist-packages/trac/util/presentation.py", line 26, in <module>
    from jinja2.utils import soft_unicode
ImportError: cannot import name 'soft_unicode' from 'jinja2.utils' (/usr/local/lib/python3.9/dist-packages/jinja2/utils.py)



Attachments (0)

Change History (4)

comment:1 by Tomasz Brzezina <tomasz@…>, 2 months ago

Description: modified (diff)

comment:2 by Jun Omae, 2 months ago

Resolution: duplicate
Status: newclosed

A duplicate of #13404.

comment:3 by Jun Omae, 2 months ago

Description: modified (diff)

in reply to:  description comment:4 by Jun Omae, 2 months ago

(BTW there's no Trac-latest.zip which is mentioned here 1.5/TracInstall)

Thanks for the reporting. I just removed the installation step using Trac-latest.zip in 1.5/TracInstall@5 (diff).

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The ticket will remain with no owner.
The resolution will be deleted. Next status will be 'reopened'.
to The owner will be changed from (none) to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.