Edgewall Software
Modify

Opened 2 years ago

Closed 2 years ago

#13227 closed defect (duplicate)

Searching email address throws UnicodeDecodeError error.

Reported by: systems@… Owned by:
Priority: normal Milestone:
Component: search system Version: 1.4
Severity: major Keywords:
Cc: Branch:
Release Notes:
API Changes:
Internal Changes:

Description (last modified by Jun Omae)

When I try to search an email (solucion@…), python is throwing such error :

2019-11-29 08:57:15,899 Trac[chrome] ERROR: Jinja2 UnicodeDecodeError error while rendering XML/HTML template
Traceback (most recent call last):
  File "/usr/lib/python2.7/site-packages/trac/web/chrome.py", line 1704, in _iterable_jinja_content
    for chunk in stream:
  File "/usr/lib64/python2.7/site-packages/jinja2/environment.py", line 1271, in __next__
    return self._next()
  File "/usr/lib64/python2.7/site-packages/jinja2/environment.py", line 1248, in _buffered_generator
    c = next(self._gen)
  File "/usr/lib64/python2.7/site-packages/jinja2/environment.py", line 1045, in generate
    yield self.environment.handle_exception(exc_info, True)
  File "/usr/lib64/python2.7/site-packages/jinja2/environment.py", line 780, in handle_exception
    reraise(exc_type, exc_value, tb)
  File "/usr/lib/python2.7/site-packages/trac/search/templates/search.html", line 12, in top-level template code
    # extends 'layout.html'
  File "/usr/lib/python2.7/site-packages/trac/templates/layout.html", line 12, in top-level template code
    # import "macros.html" as jmacros with context
  File "/usr/lib/python2.7/site-packages/trac/templates/theme.html", line 22, in top-level template code
    # block body
  File "/usr/lib/python2.7/site-packages/trac/templates/theme.html", line 128, in block "body"
    # block content
  File "/usr/lib/python2.7/site-packages/trac/search/templates/search.html", line 79, in block "content"
    _('Quickjump to %(name)s', name=quickjump.name)|safe}</a>
  File "/usr/lib64/python2.7/site-packages/jinja2/filters.py", line 887, in do_mark_safe
    return Markup(value)
  File "/usr/lib64/python2.7/site-packages/markupsafe/__init__.py", line 74, in __new__
    return text_type.__new__(cls, base)
UnicodeDecodeError: 'ascii' codec can't decode byte 0xe2 in position 36: ordinal not in range(128)

The same search with solución@domain.ltd returns a valid result and doesn't generate the error above.

Attachments (0)

Change History (1)

comment:1 by Jun Omae, 2 years ago

Description: modified (diff)
Resolution: duplicate
Status: newclosed

A duplicate of #13212.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The ticket will remain with no owner.
The resolution will be deleted. Next status will be 'reopened'.
to The owner will be changed from (none) to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.