Edgewall Software
Modify

Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#13123 closed defect (fixed)

Travis builds broken for Python 2.6

Reported by: Christian Boos Owned by: Jun Omae
Priority: normal Milestone: 1.0.18
Component: general Version:
Severity: normal Keywords: travis-ci
Cc: Branch:
Release Notes:
API Changes:
Internal Changes:

Description

Last night, the Travis builds for the stable branches failed because the Python 2.6 builds failed to install their required packages.

One of the last successful one was Build #354 / Job #3545.1:

DEPRECATION: Python 2.6 is no longer supported by the Python core team, please upgrade your Python. A future version of pip will drop support for Python 2.6
Collecting Genshi>=0.7
/home/travis/virtualenv/python2.6.9/lib/python2.6/site-packages/pip/_vendor/requests/packages/urllib3/util/ssl_.py:318: SNIMissingWarning: An HTTPS request has been made, but the SNI (Subject Name Indication) extension to TLS is not available on this platform. This may cause the server to present an incorrect TLS certificate, which can cause validation failures. You can upgrade to a newer version of Python to solve this. For more information, see https://urllib3.readthedocs.io/en/latest/security.html#snimissingwarning.
  SNIMissingWarning
/home/travis/virtualenv/python2.6.9/lib/python2.6/site-packages/pip/_vendor/requests/packages/urllib3/util/ssl_.py:122: InsecurePlatformWarning: A true SSLContext object is not available. This prevents urllib3 from configuring SSL appropriately and may cause certain SSL connections to fail. You can upgrade to a newer version of Python to solve this. For more information, see https://urllib3.readthedocs.io/en/latest/security.html#insecureplatformwarning.
  InsecurePlatformWarning
Collecting lxml
Collecting twill==0.9.1
Collecting Pygments
  Using cached https://files.pythonhosted.org/packages/13/e5/6d710c9cf96c31ac82657bcfb441df328b22df8564d58d0c4cd62612674c/Pygments-2.3.1-py2.py3-none-any.whl
Collecting docutils
  Using cached https://files.pythonhosted.org/packages/50/09/c53398e0005b11f7ffb27b7aa720c617aba53be4fb4f4f3f06b9b5c60f28/docutils-0.14-py2-none-any.whl
Collecting textile
  Using cached https://files.pythonhosted.org/packages/dc/72/c4c0c86d27e1bd4027ae8881bb4ebd208d1232c8d091c0b2254fdc709d63/textile-3.0.3-py2.py3-none-any.whl
Collecting pytz
  Using cached https://files.pythonhosted.org/packages/f8/0e/2365ddc010afb3d79147f1dd544e5ee24bf4ece58ab99b16fbb465ce6dc0/pytz-2018.7-py2.py3-none-any.whl
Collecting Babel<2.6.0
  Using cached https://files.pythonhosted.org/packages/94/03/14e68ad12e771a79cf96792f7158d68a7b3d8c7b2badf39e9ef1f65b57d6/Babel-2.5.3-py2.py3-none-any.whl
Collecting html5lib>=0.999999999 (from textile)
  Using cached https://files.pythonhosted.org/packages/a5/62/bbd2be0e7943ec8504b517e62bab011b4946e1258842bc159e5dfde15b96/html5lib-1.0.1-py2.py3-none-any.whl
Requirement already satisfied: ordereddict>=1.1; python_version == "2.6" in /home/travis/virtualenv/python2.6.9/lib/python2.6/site-packages (from textile)
Requirement already satisfied: six in /home/travis/virtualenv/python2.6.9/lib/python2.6/site-packages (from textile)
Collecting webencodings (from html5lib>=0.999999999->textile)
  Using cached https://files.pythonhosted.org/packages/f4/24/2a3e3df732393fed8b3ebf2ec078f05546de641fe1b667ee316ec1dcf3b7/webencodings-0.5.1-py2.py3-none-any.whl
Installing collected packages: Genshi, lxml, twill, Pygments, docutils, webencodings, html5lib, textile, pytz, Babel
Successfully installed Babel-2.5.3 Genshi-0.7.1 Pygments-2.3.1 docutils-0.14 html5lib-1.0.1 lxml-4.2.5 pytz-2018.7 textile-3.0.3 twill-0.9.1 webencodings-0.5.1

We can see that the "older" packages are fetched from the cache.

The failing build says:

DEPRECATION: Python 2.6 is no longer supported by the Python core team, please upgrade your Python. A future version of pip will drop support for Python 2.6
Collecting Genshi>=0.7
/home/travis/virtualenv/python2.6.9/lib/python2.6/site-packages/pip/_vendor/requests/packages/urllib3/util/ssl_.py:318: SNIMissingWarning: An HTTPS request has been made, but the SNI (Subject Name Indication) extension to TLS is not available on this platform. This may cause the server to present an incorrect TLS certificate, which can cause validation failures. You can upgrade to a newer version of Python to solve this. For more information, see https://urllib3.readthedocs.io/en/latest/security.html#snimissingwarning.
  SNIMissingWarning
/home/travis/virtualenv/python2.6.9/lib/python2.6/site-packages/pip/_vendor/requests/packages/urllib3/util/ssl_.py:122: InsecurePlatformWarning: A true SSLContext object is not available. This prevents urllib3 from configuring SSL appropriately and may cause certain SSL connections to fail. You can upgrade to a newer version of Python to solve this. For more information, see https://urllib3.readthedocs.io/en/latest/security.html#insecureplatformwarning.
  InsecurePlatformWarning
Collecting configobj
Collecting Pygments
  Using cached https://files.pythonhosted.org/packages/13/e5/6d710c9cf96c31ac82657bcfb441df328b22df8564d58d0c4cd62612674c/Pygments-2.3.1-py2.py3-none-any.whl
Collecting docutils
  Using cached https://files.pythonhosted.org/packages/50/09/c53398e0005b11f7ffb27b7aa720c617aba53be4fb4f4f3f06b9b5c60f28/docutils-0.14-py2-none-any.whl
Collecting textile
  Using cached https://files.pythonhosted.org/packages/dc/72/c4c0c86d27e1bd4027ae8881bb4ebd208d1232c8d091c0b2254fdc709d63/textile-3.0.3-py2.py3-none-any.whl
Collecting lxml
/home/travis/virtualenv/python2.6.9/lib/python2.6/site-packages/pip/_vendor/requests/packages/urllib3/util/ssl_.py:122: InsecurePlatformWarning: A true SSLContext object is not available. This prevents urllib3 from configuring SSL appropriately and may cause certain SSL connections to fail. You can upgrade to a newer version of Python to solve this. For more information, see https://urllib3.readthedocs.io/en/latest/security.html#insecureplatformwarning.
  InsecurePlatformWarning
  Downloading https://files.pythonhosted.org/packages/16/4a/b085a04d6dad79aa5c00c65c9b2bbcb2c6c22e5ac341e7968e0ad2c57e2f/lxml-4.3.0.tar.gz (2.5MB)
    100% |████████████████████████████████| 2.5MB 560kB/s 
    Complete output from command python setup.py egg_info:
    This lxml version requires Python 2.7, 3.4 or later.
    
    ----------------------------------------
Command "python setup.py egg_info" failed with error code 1 in /tmp/pip-build-ER22wI/lxml/
Traceback (most recent call last):
  File "<string>", line 1, in <module>
  File "/home/travis/virtualenv/python2.6.9/lib/python2.6/site-packages/pkg_resources/__init__.py", line 967, in require
    needed = self.resolve(parse_requirements(requirements))
  File "/home/travis/virtualenv/python2.6.9/lib/python2.6/site-packages/pkg_resources/__init__.py", line 853, in resolve
    raise DistributionNotFound(req, requirers)
pkg_resources.DistributionNotFound: The 'Babel<2.6.0' distribution was not found and is required by the application
DEPRECATION: Python 2.6 is no longer supported by the Python core team, please upgrade your Python. A future version of pip will drop support for Python 2.6
Package     Version 
----------- --------
argparse    1.4.0   
funcsigs    1.0.2   
mock        2.0.0   
nose        1.3.7   
numpy       1.11.2  
ordereddict 1.1     
pbr         1.10.0  
pip         9.0.1   
py          1.4.31  
pytest      3.0.3   
setuptools  28.8.0  
six         1.10.0  
wheel       0.30.0a0

As it's an all or nothing thing, Genshi is not installed due to the failure to install Babel.

There's probably a way to point to the archive directly.

Attachments (0)

Change History (6)

comment:1 by Jun Omae, 4 years ago

We could pin the version of lxml for Python 2.6:

  • .travis.yml

    commit 8a0f540455290c658a694d63c419591acae893dd (HEAD -> t13123+1.2-stable, github/t13123+1.2-stable)
    Author: Jun Omae <jun66j5@gmail.com>
    Date:   Tue Jan 8 18:02:24 2019 +0900
    
        (#13123) pin lxml<4.3.0 for Python 2.6 on Travis CI configuration
    
    diff --git a/.travis.yml b/.travis.yml
    index ae6df4648..1811d27c0 100644
    a b install:  
    148148      python -c 'from svn import core'
    149149    fi
    150150  - |
    151     requires='Genshi>=0.7 lxml twill==0.9.1'
     151    requires='Genshi>=0.7 twill==0.9.1'
     152    case "$pyver" in
     153      2.6) requires="$requires lxml<4.3.0" ;;
     154      *)   requires="$requires lxml" ;;
     155    esac
    152156    if [ "$build" != minimum ]; then
    153157      requires="$requires Pygments docutils textile pytz"
    154158      case "$pyver" in

The same issue exists on 1.0-stable, Build #3548 - edgewall/trac - Travis CI.

Last edited 4 years ago by Jun Omae (previous) (diff)

comment:2 by Christian Boos, 4 years ago

The build #3571 (e.g. Job #3573.1) for r16872 with the patch from comment:1 passed, as it managed to install lxml 4.2.6.

Looks like the Babel error was a transient one (Babel 2.5.3 got installed this time).

comment:3 by Christian Boos, 4 years ago

Resolution: fixed
Status: newclosed

Merged in r16873 on 1.2-stable which also has Python 2.6, but record-merge only on trunk (r16874) as we only have Python 2.7 there.

comment:4 by Christian Boos, 4 years ago

Owner: set to Jun Omae

comment:5 by Ryan J Ollos, 4 years ago

Milestone: 1.2.41.0.18

comment:6 by Ryan J Ollos, 4 years ago

Keywords: travis-ci added; travis removed

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Jun Omae.
The resolution will be deleted. Next status will be 'reopened'.
to The owner will be changed from Jun Omae to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.