Edgewall Software
Modify

Opened 2 years ago

Closed 2 years ago

#13065 closed enhancement (worksforme)

TicketQuery macro in compact mode has no delimiting white space

Reported by: figaro Owned by:
Priority: normal Milestone:
Component: ticket system Version:
Severity: minor Keywords:
Cc: Branch:
Release Notes:
API Changes:
Internal Changes:

Description

Note how the compact mode of the TicketQuery macro does not have spaces, just commas: TicketQuery#Format:compact

This reduces legibility. Therefore I propose to add a space after every comma.

Note furthermore that this is not the case on Trac-hacks, therefore this is possibly a regression. In other words, the following macro call displays differently on t.e.o. vs Trac-hacks:

[[TicketQuery(status=!closed, keywords=~patch, order=priority, milestone=!unscheduled, group=milestone, format=compact)]]

Attachments (0)

Change History (5)

comment:1 by Peter Suter, 2 years ago

Spaces do appear for me, and text selection and viewing selection source confirm they are there.

Maybe you see smaller spaces due to the selected font? Browsers (Firefox, Chrome, Edge) allow inspecting and experimentally changing the font of an element. Trac-hacks doesn't have the new fonts (#12640) yet.

in reply to:  description comment:2 by Jun Omae, 2 years ago

Replying to figaro:

Note furthermore that this is not the case on Trac-hacks, therefore this is possibly a regression. In other words, the following macro call displays differently on t.e.o. vs Trac-hacks:

[[TicketQuery(status=!closed, keywords=~patch, order=priority, milestone=!unscheduled, group=milestone, format=compact)]]

Trac-hacks has no defined milestones. Then, group=milestone doesn't take effect.

Last edited 2 years ago by Jun Omae (previous) (diff)

comment:3 by Jun Omae, 2 years ago

I suggest to close as worksforme or wontfix.

comment:4 by Peter Suter, 2 years ago

Oh, so this is about the ticket query links:

Wiki Markup Result
[[TicketQuery(id=1|2, format=compact)]] #1, #2
[[TicketQuery(id=1|2, format=compact, group=reporter)]] anonymous #1,​2
#1,2 #1,​2
#1, #2 #1, #2
#1, 2 #1, 2

That seems intentional and sensible to me.

For example using group=status also demonstrates it on Trac-hacks.

comment:5 by Peter Suter, 2 years ago

Resolution: worksforme
Status: newclosed

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The ticket will remain with no owner.
The resolution will be deleted. Next status will be 'reopened'.
to The owner will be changed from (none) to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.