Edgewall Software
Modify

Opened 2 years ago

Closed 2 years ago

Last modified 2 years ago

#13024 closed enhancement (duplicate)

Add project table and columns

Reported by: anonymous Owned by:
Priority: normal Milestone:
Component: ticket system Version:
Severity: normal Keywords: multiproject
Cc: Branch:
Release Notes:
API Changes:
Internal Changes:

Description

The first simple step for multi-project support (#11025):

  1. Add a project table.
  2. Add a project column to the ticket table.
  3. Add admin panel and admin commands to manage the projects.

That's already useful (better than nothing). And completely optional: Like components or severities and so on, if no entries are added to the project table, this feature is completely invisible.

The next step:

  1. Add milestone.project and version.project columns.
  2. Filter milestones and versions by the ticket's current project.

That makes it more useful. More steps can be postponed to later.

Maybe finally the major feature in Trac 1.5?

Attachments (5)

project_table.diff (22.7 KB ) - added by anonymous 2 years ago.
version_milestone_per_project.diff (11.2 KB ) - added by anonymous 2 years ago.
project_table_v2.diff (37.8 KB ) - added by anonymous 2 years ago.
version_milestone_per_project_v2.diff (22.4 KB ) - added by anonymous 2 years ago.
filter_v2.diff (4.7 KB ) - added by anonymous 2 years ago.

Download all attachments as: .zip

Change History (10)

by anonymous, 2 years ago

Attachment: project_table.diff added

by anonymous, 2 years ago

comment:1 by anonymous, 2 years ago

project_table.diff implements steps 1 to 3; version_milestone_per_project.diff step 4. Is it worth already to continue on step 5?

comment:2 by Jun Omae, 2 years ago

Milestone: topic-multiproject
Resolution: duplicate
Status: newclosed

A duplicate of #11025.

comment:3 by Ryan J Ollos, 2 years ago

You could raise the topic on the trac-dev MailingList, but in general I don't favor adding little pieces of multi-project without a definite plan for implementing the whole feature. The feature will be a huge amount of work and there are many design decisions to be made, which is why it hasn't been done yet.

If you want to make some contributions to Trac there are many things you could work on that have a more reasonable scope. Let me know if you want suggestions.

by anonymous, 2 years ago

Attachment: project_table_v2.diff added

by anonymous, 2 years ago

by anonymous, 2 years ago

Attachment: filter_v2.diff added

comment:4 by anonymous, 2 years ago

Fixed some tests, added projects to version and milestone UI, and added filtering.

comment:5 by Jun Omae, 2 years ago

Please share your suggestions before posting incomplete patches.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The ticket will remain with no owner.
The resolution will be deleted. Next status will be 'reopened'.
to The owner will be changed from (none) to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.