Edgewall Software
Modify

Opened 15 years ago

Closed 14 years ago

Last modified 13 years ago

#1302 closed defect (fixed)

Crash when clicked "WikiRestructuredTextLinks"

Reported by: dserodio@… Owned by: Jonas Borgström
Priority: high Milestone: 0.8.2
Component: wiki system Version: 0.8.1
Severity: major Keywords: docutils
Cc: Branch:
Release Notes:
API Changes:

Description

I installed trac, clicked on "Timeline", then "WikiRestructuredTextLinks", and got the following error:

Traceback (most recent call last):
  File "/usr/lib/python2.3/site-packages/trac/core.py", line 525, in cgi_start
    real_cgi_start()
  File "/usr/lib/python2.3/site-packages/trac/core.py", line 520, in real_cgi_start
    dispatch_request(path_info, args, req, env)
  File "/usr/lib/python2.3/site-packages/trac/core.py", line 435, in dispatch_request
    module.run()
  File "/usr/lib/python2.3/site-packages/trac/Module.py", line 44, in run
    self.render()
  File "/usr/lib/python2.3/site-packages/trac/Wiki.py", line 339, in render
    Formatter(self.req.hdf, self.env,self.db).format(self.page.text, out)
  File "/usr/lib/python2.3/site-packages/trac/WikiFormatter.py", line 549, in format
    self.handle_code_block(line)
  File "/usr/lib/python2.3/site-packages/trac/WikiFormatter.py", line 505, in handle_code_block
    self.out.write(self.code_processor(self.hdf, self.code_text, self.env))
  File "/usr/lib/python2.3/site-packages/trac/wikimacros/rst.py", line 209, in execute
    settings_overrides = {'halt_level':6})
  File "/usr/lib/site-python/docutils/core.py", line 371, in publish_string
    enable_exit_status=enable_exit_status)
  File "/usr/lib/site-python/docutils/core.py", line 513, in publish_programmatically
    output = pub.publish(enable_exit_status=enable_exit_status)
  File "/usr/lib/site-python/docutils/core.py", line 196, in publish
    output = self.writer.write(document, self.destination)
  File "/usr/lib/site-python/docutils/writers/__init__.py", line 72, in write
    self.translate()
  File "/usr/lib/site-python/docutils/writers/html4css1.py", line 103, in translate
    self.document.walkabout(visitor)
  File "/usr/lib/site-python/docutils/nodes.py", line 153, in walkabout
    child.walkabout(visitor)
  File "/usr/lib/site-python/docutils/nodes.py", line 153, in walkabout
    child.walkabout(visitor)
  File "/usr/lib/site-python/docutils/nodes.py", line 153, in walkabout
    child.walkabout(visitor)
  File "/usr/lib/site-python/docutils/nodes.py", line 153, in walkabout
    child.walkabout(visitor)
  File "/usr/lib/site-python/docutils/nodes.py", line 153, in walkabout
    child.walkabout(visitor)
  File "/usr/lib/site-python/docutils/nodes.py", line 145, in walkabout
    visitor.dispatch_visit(self)
  File "/usr/lib/site-python/docutils/nodes.py", line 1323, in dispatch_visit
    return method(node)
  File "/usr/lib/site-python/docutils/writers/html4css1.py", line 1050, in visit_reference
    assert len(node) == 1 and isinstance(node[0], nodes.image)
AssertionError

Attachments (0)

Change History (17)

comment:1 by cboos@…, 15 years ago

From TracInstall: docutils, version ≥ 0.3.3 (??) for WikiRestructuredText

What docutils version are you using?

comment:2 by Artur (x-phile@…, 15 years ago

I get this error too. I tried docutils 0.3.7 and then latest development snapshot. Both on Windows and Linux. Maybe some older docutils version will work?

comment:3 by anonymous, 15 years ago

I'm using docutils 0.3.7-2 (the -2 is the Debian revision). What version is Trac known to work with?

comment:4 by Christian Boos, 15 years ago

That might be too recent… I'm using 0.3.5 on Windows and Linux without any problem.

comment:5 by Artur (x-phile@…, 15 years ago

Yes, 0.3.5 works fine. But IMO this incompatibility should be mentioned in Trac's documentation.

comment:6 by Christian Boos, 15 years ago

I added a link to this ticket in TracInstall

comment:7 by Mark Rowe, 15 years ago

#1342 was closed as a duplicate of this bug.

comment:8 by Mark Rowe, 14 years ago

A lot of digging reveals that this is specific to the directive form of link, such as .. trac:: #1. As it is a child of the "document" rather than a paragraph or such, docutils appears to take a code path that expects that it is an image. I'm not familiar enough with the internals of docutils to determine where the problem lies.

comment:9 by Mark Rowe, 14 years ago

Component: generalwiki
Keywords: docutils added
Milestone: 0.9
Priority: normalhigh
Severity: normalmajor

comment:10 by Otavio Salvador, 14 years ago

This bug was report to BTS of Debian project. Please do a look at: http://bugs.debian.org/301151.

I hope we can solve this before sarge since could be good to have a solid release in a so used distribution. Please, if possible, advice me if have news about it.

comment:11 by Otavio Salvador, 14 years ago

Another possible thing is this bug be on docutils and not on trac. In this case I can contact the docutils maintainer and ask for a comment about it.

comment:12 by Mark Rowe, 14 years ago

I would appreciate it if you could discuss it with someone familiar with docutils.

comment:13 by Otavio Salvador, 14 years ago

I sent a mail to docutils maintainer, on Debian, asking about it and then he sent it to developers mailing list. I hope we should receive some information about it near.

Only one thing I don't agree with you is about the milestone of bug. I think it should be fixed for 0.8.2 and ASAP since it's a serious bug and it's hit a lot of users. Since it ocour after a clean install, it may cause a bad "first impression".

comment:14 by Mark Rowe, 14 years ago

Milestone: 0.90.8.2

Thanks. I agree about the milestone.

comment:15 by otavio@…, 14 years ago

The message posted by docutils's maintainer can be viewed at:

http://sourceforge.net/mailarchive/forum.php?thread_id=6915620&forum_id=8812

comment:16 by Mark Rowe, 14 years ago

Resolution: fixed
Status: newclosed

Fixed in [1458] and merged to 0.8-stable branch in [1459]. Thanks for following this up otavio.

comment:17 by Otavio Salvador, 14 years ago

You're welcome. I also did a upload to Debian fixing this bug and doing another trivial packaging related fix.

Thanks again.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Jonas Borgström.
The resolution will be deleted. Next status will be 'reopened'.
to as closed The owner will be changed from Jonas Borgström to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.