Edgewall Software
Modify

Opened 4 years ago

Closed 4 years ago

#13001 closed enhancement (duplicate)

E-mail with description changes overwhelming

Reported by: Dirk Stöcker Owned by:
Priority: normal Milestone:
Component: notification Version: 1.2.2
Severity: normal Keywords:
Cc: Branch:
Release Notes:
API Changes:
Internal Changes:

Description

When a ticket description is changed the e-mail contains the old and the new text. For short texts this is fine, but for most this is simply too long. When displaying the ticket you can show the difference instead, which is helpful.

Please change the notification, so instead of old+new it sends a diff, probably in unified diff format. That would be extremely helpful.

Attachments (0)

Change History (3)

comment:1 by anonymous, 4 years ago

#3914 has an old patch for this.

comment:2 by Jun Omae, 4 years ago

Agreed.

In my production environment, unified diff is provided for changes of the description field as text/plain and text/html formats in ticket notification mail, using custom formatter for AnnouncerPlugin on Trac 1.0.x.

comment:3 by Ryan J Ollos, 4 years ago

Resolution: duplicate
Status: newclosed

Also agreed, but closing as duplicate of #3914.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The ticket will remain with no owner.
The resolution will be deleted. Next status will be 'reopened'.
to The owner will be changed from (none) to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.