Edgewall Software
Modify

Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#12981 closed enhancement (worksforme)

Suppress pagename in fragment links to anchors on same page

Reported by: Hb--- Owned by:
Priority: normal Milestone:
Component: wiki system Version:
Severity: normal Keywords:
Cc: Branch:
Release Notes:
API Changes:
Internal Changes:

Description

A link to an anchor on the same page can be made with [#fragment some text]. But generated is <a href="wiki/pagename#fragment">.

The non local part wiki/pagename forces the browser to sent an unnecessary HTTP request.

A test in def _format_link should be done if the target pagename is the current pagename. If yes, the pagename should not be added to the link.

Attachments (0)

Change History (1)

comment:1 by Jun Omae, 3 years ago

Keywords: anchor URI link removed
Resolution: worksforme
Status: newclosed

Cannot reproduce it. Such redundant request is not sent with Firefox, Google Chrome and Internet Edge.

Test page: demo-1.0/wiki/SandBox/Ticket/12981

Last edited 3 years ago by Jun Omae (previous) (diff)

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The ticket will remain with no owner.
The resolution will be deleted. Next status will be 'reopened'.
to The owner will be changed from (none) to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.