Edgewall Software
Modify

Opened 20 months ago

Closed 20 months ago

Last modified 20 months ago

#12968 closed defect (fixed)

preview_file.html rev 16379 (via include in browser.html): "ParseError: mismatched tag" caused by dangling </p>

Reported by: richard@… Owned by: richard@…
Priority: normal Milestone: 1.3.3
Component: version control/browser Version: 1.3dev
Severity: normal Keywords:
Cc: Branch:
Release Notes:

Fix unbalanced </p> in preview_file.html.

API Changes:

Description (last modified by Jun Omae)

Lines 50 and 51 of preview_file.html of r16379 need to be swapped so that the final </p> on line 51 is enclosed in the final # endif, otherwise the dangling </p> generated by preview_file.html will report the error ParseError: mismatched tag: line ###, column # when trying to view a file in the repo.

Please see preview_file.html rev 16379: source:/trunk/trac/templates/preview_file.html@16379#L51

In the current trunk source code, this can be reproduced simply by clicking on any link to a file in the repo that results in use of the browser.html template that includes preview_file.html.

I've attached a patch that solves for this bug.

NOTE: I'd be happy to make such corrections directly if I were given access to make changes in the Trac trunk.

Thanks for all your help making Trac what it is today.

Attachments (1)

preview_file.html.patch (271 bytes ) - added by richard@… 20 months ago.
swap lines 50 and 51 of preview_file.html to correct "ParseError: mismatched tag" caused by dangling </p>

Download all attachments as: .zip

Change History (5)

by richard@…, 20 months ago

Attachment: preview_file.html.patch added

swap lines 50 and 51 of preview_file.html to correct "ParseError: mismatched tag" caused by dangling </p>

comment:1 by Jun Omae, 20 months ago

Description: modified (diff)

comment:2 by Jun Omae, 20 months ago

Thanks for the reporting. We will apply the patch but should add unit tests for the regression.

comment:3 by Jun Omae, 20 months ago

Release Notes: modified (diff)
Resolution: fixed
Status: newclosed

Fixed in [16412].

comment:4 by Jun Omae, 20 months ago

Owner: set to richard@…

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain richard@….
The resolution will be deleted. Next status will be 'reopened'.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.