Edgewall Software
Modify

Opened 3 years ago

Closed 3 years ago

Last modified 19 months ago

#12961 closed defect (fixed)

Latest wheel doesn't work with Python 2.6 on Travis CI

Reported by: Jun Omae Owned by: Jun Omae
Priority: normal Milestone: 1.0.17
Component: general Version:
Severity: normal Keywords:
Cc: Branch:
Release Notes:

Use latest setuptools, pip and wheel only when Python 2.7.

API Changes:
Internal Changes:

Description

https://travis-ci.org/edgewall/trac/jobs/313949552#L208

Building wheels for collected packages: Genshi, configobj, lxml, twill, ordereddict
  Running setup.py bdist_wheel for Genshi ... error
  Complete output from command /Users/travis/venv-2.6/bin/python2.6 -u -c "import setuptools, tokenize;__file__='/private/var/folders/bb/n7t3rs157850byt_jfdcq9k80000gn/T/pip-build-m4N0rc/Genshi/setup.py';f=getattr(tokenize, 'open', open)(__file__);code=f.read().replace('\r\n', '\n');f.close();exec(compile(code, __file__, 'exec'))" bdist_wheel -d /var/folders/bb/n7t3rs157850byt_jfdcq9k80000gn/T/tmpDyj4gqpip-wheel- --python-tag cp26:
  /private/var/folders/bb/n7t3rs157850byt_jfdcq9k80000gn/T/pip-build-m4N0rc/Genshi/setup.py:72: DeprecationWarning: Features are deprecated and will be removed in a future version. See https://github.com/pypa/setuptools/issues/65.
    Extension('genshi._speedups', ['genshi/_speedups.c']),
  /System/Library/Frameworks/Python.framework/Versions/2.6/lib/python2.6/distutils/core.py:113: DeprecationWarning: Features are deprecated and will be removed in a future version. See https://github.com/pypa/setuptools/issues/65.
    _setup_distribution = dist = klass(attrs)
  Traceback (most recent call last):
    File "<string>", line 1, in <module>
    File "/private/var/folders/bb/n7t3rs157850byt_jfdcq9k80000gn/T/pip-build-m4N0rc/Genshi/setup.py", line 162, in <module>
      **extra
    File "/Users/travis/venv-2.6/lib/python2.6/site-packages/setuptools/__init__.py", line 129, in setup
      return distutils.core.setup(**attrs)
    File "/System/Library/Frameworks/Python.framework/Versions/2.6/lib/python2.6/distutils/core.py", line 138, in setup
      ok = dist.parse_command_line()
    File "/Users/travis/venv-2.6/lib/python2.6/site-packages/setuptools/dist.py", line 439, in parse_command_line
      result = _Distribution.parse_command_line(self)
    File "/System/Library/Frameworks/Python.framework/Versions/2.6/lib/python2.6/distutils/dist.py", line 460, in parse_command_line
      args = self._parse_command_opts(parser, args)
    File "/Users/travis/venv-2.6/lib/python2.6/site-packages/setuptools/dist.py", line 754, in _parse_command_opts
      nargs = _Distribution._parse_command_opts(self, parser, args)
    File "/System/Library/Frameworks/Python.framework/Versions/2.6/lib/python2.6/distutils/dist.py", line 518, in _parse_command_opts
      cmd_class = self.get_command_class(command)
    File "/Users/travis/venv-2.6/lib/python2.6/site-packages/setuptools/dist.py", line 574, in get_command_class
      self.cmdclass[command] = cmdclass = ep.load()
    File "/Users/travis/venv-2.6/lib/python2.6/site-packages/pkg_resources/__init__.py", line 2422, in load
      return self.resolve()
    File "/Users/travis/venv-2.6/lib/python2.6/site-packages/pkg_resources/__init__.py", line 2428, in resolve
      module = __import__(self.module_name, fromlist=['__name__'], level=0)
    File "/Users/travis/venv-2.6/lib/python2.6/site-packages/wheel/bdist_wheel.py", line 407
      ignore=lambda x, y: {'PKG-INFO', 'requires.txt', 'SOURCES.txt',
                                     ^
  SyntaxError: invalid syntax

However, build doesn't stop.

Attachments (0)

Change History (5)

comment:1 by Ryan J Ollos, 3 years ago

Looks like they dropped support for Python 2.6 in Wheel 0.30.0 (release notes), so we'll need to pin the dependency at wheel==0.29.0.

comment:2 by Jun Omae, 3 years ago

Owner: set to Jun Omae
Status: newassigned

Sure. However, latest wheel package is automatically downloaded and installed when creating virtualenv. It cannot be pinned. Instead, it is needed to use --no-download option to prevent the behavior.

[b118a7647/jomae.git] (jomae.git@t12961).

Last edited 3 years ago by Jun Omae (previous) (diff)

comment:3 by Jun Omae, 3 years ago

Added [2fb46954b/jomae.git] which verifies requires packages are installed. Confirmed wheel 0.29.0 is used when Python 2.6 on OS X. See https://travis-ci.org/jun66j5/trac/jobs/331491205.

Also, I think we should show versions of pip and wheel via make status.

  • contrib/make_status.py

    diff --git a/contrib/make_status.py b/contrib/make_status.py
    index a7e24ec95..b08a5c094 100755
    a b def _genshi_version():  
    2828PACKAGES = [
    2929    ("Python",            'sys.version'),
    3030    ("Setuptools",        'setuptools.__version__'),
     31    ("Pip",               'pip.__version__'),
     32    ("Wheel",             'wheel.__version__'),
    3133    ("Genshi",            '__main__._genshi_version()'),
    3234    ("Babel",             'babel.__version__'),
    3335    ("sqlite3",           ('sqlite3.version',

comment:4 by Ryan J Ollos, 3 years ago

comment:3 changes look good to me.

comment:5 by Jun Omae, 3 years ago

Release Notes: modified (diff)
Resolution: fixed
Status: assignedclosed

Committed in [16426-16427] and merged in [16428-16429].

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Jun Omae.
The resolution will be deleted. Next status will be 'reopened'.
to The owner will be changed from Jun Omae to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.