Edgewall Software
Modify

Opened 2 years ago

Closed 2 years ago

#12919 closed defect (fixed)

Reports with a single column look strange

Reported by: anonymous Owned by: Jun Omae
Priority: normal Milestone: 1.3.3
Component: report system Version: 1.3dev
Severity: normal Keywords:
Cc: Branch:
Release Notes:

Fix malformed html being rendered when a report has only one column.

API Changes:

Description

For example the following report with a single column looks very strange:

SELECT DISTINCT keywords
FROM ticket

(Because each row contains a superfluous horizontal line with a lot of vertical space.)

Adding a second column seems to avoid this problem:

SELECT DISTINCT keywords, 'unwanted second column'
FROM ticket

Attachments (3)

report-single-column.png (9.0 KB ) - added by Jun Omae 2 years ago.
report-multi-columns.png (13.2 KB ) - added by Jun Omae 2 years ago.
keywords.png (48.9 KB ) - added by anonymous 2 years ago.

Download all attachments as: .zip

Change History (8)

by Jun Omae, 2 years ago

Attachment: report-single-column.png added

by Jun Omae, 2 years ago

Attachment: report-multi-columns.png added

comment:1 by Jun Omae, 2 years ago

Keywords: needinfo added
Milestone: undecided

Are you using what version of Trac with what database?

It seems to be correct.

by anonymous, 2 years ago

Attachment: keywords.png added

comment:2 by anonymous, 2 years ago

  • Trac 1.3.2dev
  • SQLite 3.6.21

comment:3 by Jun Omae, 2 years ago

Keywords: needinfo removed
Milestone: undecided1.3.3
Version: 1.3dev

Thanks for the feedback. It is caused by duplicated class attribute. We will fix report_view.html.

<td class="keywords"  class="fullrow" colspan="100">

comment:4 by Jun Omae, 2 years ago

Owner: set to Jun Omae
Status: newassigned

Proposed changes in [8aa752607/jomae.git] (jomae.git@t12919).

The changes add jinja2.ext.do to invoke list.append and dict.update in Jinja2 template.

comment:5 by Jun Omae, 2 years ago

Release Notes: modified (diff)
Resolution: fixed
Status: assignedclosed

Fixed in [16361].

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Jun Omae.
The resolution will be deleted. Next status will be 'reopened'.
to as closed The owner will be changed from Jun Omae to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.