Edgewall Software
Modify

Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#12908 closed enhancement (duplicate)

Make cmd_close ticket status configurable

Reported by: anonymous Owned by:
Priority: normal Milestone:
Component: general Version: 1.2.2
Severity: normal Keywords:
Cc: Branch:
Release Notes:
API Changes:
Internal Changes:

Description

We have an SVN post-commit hook calling /usr/bin/trac-admin ${TRAC_ENV} changeset added "$1" "$2" on each commit. The problem is that we have a custom workflow that makes sure all dev tickets that are fixed go into a verify state before being closed by QA. However, a commit that fixes #1234 - ... will outright close the ticket. We would like to be able to move it to the verify state instead.

Looking at the code, I see that commit_updater.py@L277 is setting the status to closed.

Could this be parameterized?

Attachments (0)

Change History (4)

comment:1 by anonymous, 5 years ago

It seems this is a dup of #11093.

comment:2 by anonymous, 5 years ago

Resolution: duplicate
Status: newclosed

comment:3 by Ryan J Ollos, 5 years ago

Milestone: 1.2.3

comment:4 by Ryan J Ollos, 5 years ago

Also duplicate of #10755.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The ticket will remain with no owner.
The resolution will be deleted. Next status will be 'reopened'.
to The owner will be changed from (none) to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.