Edgewall Software
Modify

Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#12901 closed defect (fixed)

Issue of Trac 1.2.2 "about" link

Reported by: johnt888@… Owned by: Jun Omae
Priority: normal Milestone: 1.0.17
Component: general Version: 1.2dev
Severity: normal Keywords: textile
Cc: Branch:
Release Notes:

Fix "About" page failing when textile is 2.1.5 or early.

API Changes:
Internal Changes:

Description

Hi -

Received the following error message when I clicked the upper right "about" link:

2017-08-30 10:42:54,812 Trac[main] ERROR: [xx.xx.xx.xx] Internal Server Error: <RequestWithSession "GET '/about'">, referrer 'https://xxxx.com:8088/trac/test_upgrade/admin'
Traceback (most recent call last):
  File "trac/1.2.2/venv/lib/python2.7/site-packages/Trac-1.2.2-py2.7.egg/trac/web/main.py", line 623, in _dispatch_request
    dispatcher.dispatch(req)
  File "trac/1.2.2/venv/lib/python2.7/site-packages/Trac-1.2.2-py2.7.egg/trac/web/main.py", line 239, in dispatch
    resp = chosen_handler.process_request(req)
  File "trac/1.2.2/venv/lib/python2.7/site-packages/Trac-1.2.2-py2.7.egg/trac/about.py", line 66, in process_request
    data['systeminfo'] = self.env.get_systeminfo()
  File "trac/1.2.2/venv/lib/python2.7/site-packages/Trac-1.2.2-py2.7.egg/trac/env.py", line 332, in get_systeminfo
    info.extend(provider.get_system_info() or [])
  File "trac/1.2.2/venv/lib/python2.7/site-packages/Trac-1.2.2-py2.7.egg/trac/mimeview/txtl.py", line 89, in get_system_info
    version = get_pkginfo(textile).get('version', textile.__version__)
AttributeError: 'module' object has no attribute '__version__'

Attachments (0)

Change History (7)

comment:1 by johnt888@…, 3 years ago

Resolution: invalid
Status: newclosed

Not sure it's related to some plugin or upgrade from an old database, a brand new database is fine. I will check more details and report back if it's required

comment:2 by Ryan J Ollos, 3 years ago

The error is in retrieving the version from the textile package (a dependency).

I would guess it's due to running an upgrade without shutting down the web server: TracUpgrade#a1.Bringyourserveroff-line.

comment:3 by Jun Omae, 3 years ago

Milestone: 1.0.16

Reproduced it.

textile.__version__ is available since textile 2.1.6, however python-textile package in Ubuntu 14.04 is 2.1.5.

$ lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description:    Ubuntu 14.04.5 LTS
Release:        14.04
Codename:       trusty
$ COLUMNS=80 dpkg --list python-textile
Desired=Unknown/Install/Remove/Purge/Hold
| Status=Not/Inst/Conf-files/Unpacked/halF-conf/Half-inst/trig-aWait/Trig-pend
|/ Err?=(none)/Reinst-required (Status,Err: uppercase=bad)
||/ Name           Version      Architecture Description
+++-==============-============-============-=================================
ii  python-textile 1:2.1.5-1bui all          Python parser for the Textile mar
$ /usr/bin/python
Python 2.7.6 (default, Oct 26 2016, 20:30:19)
[GCC 4.8.4] on linux2
Type "help", "copyright", "credits" or "license" for more information.
>>> from pkg_resources import get_distribution
>>> dist = get_distribution('textile')
>>> dist
textile 2.1.5 (/usr/lib/python2.7/dist-packages)
>>> dist.version
'2.1.5'
>>> import textile
>>> textile
<module 'textile' from '/usr/lib/python2.7/dist-packages/textile/__init__.pyc'>
>>> textile.__version__
Traceback (most recent call last):
  File "<stdin>", line 1, in <module>
AttributeError: 'module' object has no attribute '__version__'
>>>

comment:4 by Jun Omae, 3 years ago

Resolution: invalid
Status: closedreopened

comment:5 by Jun Omae, 3 years ago

Owner: set to Jun Omae
Status: reopenedassigned

Proposed changes in [1a2b9d230/jomae.git] (jomae.git@t12901).

comment:6 by Jun Omae, 3 years ago

Keywords: textile added
Release Notes: modified (diff)
Resolution: fixed
Status: assignedclosed

Fixed in [16311] and merged in [16312-16313].

comment:7 by Ryan J Ollos, 3 years ago

Milestone: 1.0.161.0.17

Milestone renamed

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Jun Omae.
The resolution will be deleted. Next status will be 'reopened'.
to The owner will be changed from Jun Omae to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.