Edgewall Software
Modify

Opened 15 years ago

Closed 14 years ago

#1284 closed enhancement (duplicate)

Possibility to create more complex workflows.

Reported by: oliver@… Owned by: Jonas Borgström
Priority: normal Milestone:
Component: ticket system Version: 0.9b2
Severity: normal Keywords: workflow permission ticket
Cc: Branch:
Release Notes:
API Changes:

Description

It would be nice if there is a possibility to define custom ticket field rights. Means the group A can see this custom ticket field, but group B e.g. not. To have a more complex functionality the permissions should be set on the custom field content basis. e.g. I create a new bug (status field = new) and only a person of group C can close the bug (- and perhaps a person of group D can set the status to tested, …). Is something like this planned in the future or is that out of scope ?

Attachments (0)

Change History (5)

comment:1 by anonymous, 15 years ago

Resolution: invalid
Status: newclosed

comment:2 by Christopher Lenz, 15 years ago

Resolution: invalid
Status: closedreopened

comment:3 by Christopher Lenz, 15 years ago

Component: generalticket system
Severity: normalenhancement

See NewWorkflow and #869, also #834.

comment:4 by leasun, 15 years ago

Version: 0.8.10.9b2

I do really need it, too. I think Trac should support assign different jobs in one workflow to different person. It will be excellent feature that only commercial software have.

comment:5 by Christian Boos, 14 years ago

Resolution: duplicate
Status: reopenedclosed

Nevertheless, that's a duplicate of #869.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Jonas Borgström.
The resolution will be deleted. Next status will be 'reopened'.
to as closed The owner will be changed from Jonas Borgström to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.