Edgewall Software
Modify

Opened 5 years ago

Closed 5 years ago

#12766 closed defect (duplicate)

Issue of "use_short_addr = true" for Trac 1.2.1 release

Reported by: johnt888@… Owned by:
Priority: normal Milestone:
Component: general Version: 1.2.1
Severity: normal Keywords:
Cc: Branch:
Release Notes:
API Changes:
Internal Changes:

Description

Trac 1.2.1 still looks for the complete email address even I set "use_short_addr = true" in "[notification]" session in trac.ini

2017-04-12 16:35:38,932 Trac[main] DEBUG: Rendering response from handler
2017-04-12 16:35:42,076 Trac[main] DEBUG: Dispatching <RequestWithSession "POST '/ticket/6'">
2017-04-12 16:35:42,077 Trac[main] DEBUG: Chosen handler is <Component trac.ticket.web_ui.TicketModule>
2017-04-12 16:35:42,079 Trac[session] DEBUG: Retrieving session for ID u'testuser'
2017-04-12 16:35:42,133 Trac[api] DEBUG: Adding (testuser [1]) for 'always' on rule (TicketUpdaterSubscriber) for (email)
2017-04-12 16:35:42,135 Trac[mail] DEBUG: EmailDistributor has found the following formats capable of handling 'email' of 'ticket': text/plain
2017-04-12 16:35:42,138 Trac[mail] DEBUG: EmailDistributor was unable to find an address for: testuser (authenticated)

Attachments (0)

Change History (2)

comment:1 by anonymous, 5 years ago

Another Debug log:

2017-04-12 16:48:30,156 Trac[web_ui] DEBUG: Side effect for ConfigurableTicketWorkflow
2017-04-12 16:48:30,238 Trac[mail] DEBUG: Invalid email address: testuser
2017-04-12 16:48:30,238 Trac[mail] DEBUG: Invalid email address: testuser
2017-04-12 16:48:30,255 Trac[mail] DEBUG: Invalid email address: testuser

comment:2 by Ryan J Ollos, 5 years ago

Resolution: duplicate
Status: newclosed

Duplicate of #12759.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The ticket will remain with no owner.
The resolution will be deleted. Next status will be 'reopened'.
to The owner will be changed from (none) to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.