Edgewall Software
Modify

Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#12760 closed defect (duplicate)

Git commit links do not work in [changeset/reponame] syntax

Reported by: strk@… Owned by:
Priority: normal Milestone:
Component: ticket system Version: 1.2
Severity: normal Keywords: git, links
Cc: Branch:
Release Notes:
API Changes:
Internal Changes:

Description

While changeset:hash/git works to reference commit hash in git repository git, the [hash/git] syntax does not work.

The https://trac.edgewall.org/wiki/TracLinks suggests it should work.

See https://trac.osgeo.org/geos/ticket/804#comment:6 and later for origin of this findings

Attachments (0)

Change History (3)

comment:1 by Peter Suter, 5 years ago

Can you try [17e0d841/git] (8+ hash characters) instead of [17e0d84/git] (7 characters)?

[302bd379/psuter.git] (8) works here, but [302bd37/psuter.git] (7) does not.

comment:2 by Peter Suter, 5 years ago

Resolution: duplicate
Status: newclosed

Also check your [git] shortrev_len and [git] wiki_shortrev_len settings.

This seems to be a duplicate of #11992.

comment:3 by anonymous, 5 years ago

Indeed using 8 chars for the hash does work, despite shortrev_len being 7 (either by default or expliclitly set) and despite wikishort_len being also 7 (explicitly set). I confirm it seems a duplicate of #11992.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The ticket will remain with no owner.
The resolution will be deleted. Next status will be 'reopened'.
to The owner will be changed from (none) to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.