Edgewall Software
Modify

Opened 2 years ago

Closed 2 years ago

Last modified 2 years ago

#12739 closed defect (cantfix)

Reply, Edit, and Delete buttons are hidden in ticket comments in Trac 1.2

Reported by: Andrew Schulman <andrex@…> Owned by:
Priority: normal Milestone:
Component: ticket system Version: 1.2
Severity: normal Keywords: missing buttons
Cc: Branch:
Release Notes:
API Changes:

Description (last modified by Andrew Schulman <andrex@…>)

Since we upgraded to Trac 1.2, the Reply and Edit buttons are hidden in all ticket comments. I know that in 1.2 they're only supposed to appear when the pointer hovers over the comment text. I try that, over the comment text or the yellow change box at right. The buttons don't appear.

The Reply and Delete buttons do appear in the ticket Description box. But not in any of the comments.

The buttons are present in the page source, inside a <div class="trac-ticket-buttons">...</div>. But they're hidden and don't become visible when the pointer hovers over the comment.

Attachments (0)

Change History (7)

comment:1 by Andrew Schulman <andrex@…>, 2 years ago

Description: modified (diff)
Summary: ticket Reply and Edit buttons are missing in Trac 1.2Reply, Edit, and Delete buttons are missing from ticket comments in Trac 1.2

comment:2 by Andrew Schulman <andrex@…>, 2 years ago

Description: modified (diff)
Summary: Reply, Edit, and Delete buttons are missing from ticket comments in Trac 1.2Reply, Edit, and Delete buttons are hidden in ticket comments in Trac 1.2

comment:3 by Christian Boos, 2 years ago

Are you sure you've deployed the correct .js resources?

In particular, check that your /chrome/common/js/threaded_comments.js matches source:tags/trac-1.2/trac/htdocs/js/threaded_comments.js.

See TracInstall#MappingStaticResources.

If it is the same, then maybe put some breakpoints around the $(".trac-ticket-buttons").css("visibility", ... lines to see if you get there. Otherwise you might have some JavaScript failures (from some plugins?) that prevent this code to be reached.

comment:4 by Ryan J Ollos, 2 years ago

in reply to:  4 comment:5 by Andrew Schulman <andrex@…>, 2 years ago

Resolution: fixed
Status: newclosed

Thank you both for your quick replies.

Replying to Christian Boos:

Are you sure you've deployed the correct .js resources?

In particular, check that your /chrome/common/js/threaded_comments.js matches source:tags/trac-1.2/trac/htdocs/js/threaded_comments.js.

Yes, I compared them and they're the same.

Replying to Ryan J Ollos:

See also gmessage:trac-users:CeulDlFVzhM/3dEYh25ZBAAJ. There, th:SectionEditPlugin was the offender.

Yep. I updated th:AutocompleteUsersPlugin, and now the buttons are back. Thanks for your help.

comment:6 by Andrew Schulman <andrex@…>, 2 years ago

Hm, not so fast. I can see the buttons on some tickets, but not on others.

Leaving this closed as it seems to be caused by some plugin, not by Trac. I'll update here when I figure it out.

comment:7 by Ryan J Ollos, 2 years ago

Resolution: fixedcantfix

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The ticket will remain with no owner.
The resolution will be deleted. Next status will be 'reopened'.
to as closed The owner will be changed from (none) to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.