Edgewall Software
Modify

Opened 5 years ago

Closed 5 years ago

#12731 closed defect (duplicate)

TypeError: %d format: a number is required, not Undefined

Reported by: Ryan J Ollos Owned by:
Priority: normal Milestone:
Component: wiki system Version:
Severity: normal Keywords:
Cc: Branch:
Release Notes:
API Changes:
Internal Changes:

Description

How to Reproduce

While doing a GET operation on /wiki/WikiStart, Trac issued an internal error.

I noticed this issue in the logs.

Request parameters:

{u'action': u'delete', 'page': u'WikiStart'}

User agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_12_3) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/57.0.2987.98 Safari/537.36

System Information

Trac 1.3.2.dev0
Babel 2.3.4
dnspython 1.12.0
Docutils 0.12
Genshi 0.7 (with speedups)
GIT 2.1.4
Jinja2 2.9.5
Mercurial 3.1.2
mod_wsgi 4.5.13 (WSGIProcessGroup trac WSGIApplicationGroup %{GLOBAL})
Pillow 2.6.1
PostgreSQL server: 9.4.10, client: 9.4.10
psycopg2 2.5.4
Pygments 2.0.1
Python 2.7.9 (default, Jun 29 2016, 13:11:10)
[GCC 4.9.2]
pytz 2012c
setuptools 34.3.1
SpamBayes 1.1b1
Subversion 1.8.10 (r1615264)
jQuery 1.11.3
jQuery UI 1.11.4
jQuery Timepicker 1.5.5

Enabled Plugins

help-guide-version-notice N/A
milestone-to-version r15098
StatusFixer r6326
TracMercurial 1.0.0.7.dev0
TracSpamFilter 1.3.0.dev0
TracVote 0.6.0.dev0
TracWikiExtras 1.3.1.dev0
TranslatedPagesMacro 0.5

Interface Customization

shared-htdocs
shared-templates
site-htdocs
site-templates site.html, site_footer.html, site_head.html, site_header.html, site_leftbox.html

Python Traceback

Traceback (most recent call last):
  File "/usr/local/virtualenv/1.3dev/lib/python2.7/site-packages/trac/web/main.py", line 632, in _dispatch_request
    dispatcher.dispatch(req)
  File "/usr/local/virtualenv/1.3dev/lib/python2.7/site-packages/trac/web/main.py", line 273, in dispatch
    method=method)
  File "/usr/local/virtualenv/1.3dev/lib/python2.7/site-packages/trac/web/chrome.py", line 1365, in render_template
    fragment, iterable, method)
  File "/usr/local/virtualenv/1.3dev/lib/python2.7/site-packages/trac/web/chrome.py", line 1457, in _render_jinja_template
    iterable)
  File "/usr/local/virtualenv/1.3dev/lib/python2.7/site-packages/trac/web/chrome.py", line 1571, in generate_template_stream
    bytes = template.render(data).encode('utf-8')
  File "/usr/local/virtualenv/1.3dev/lib/python2.7/site-packages/jinja2/environment.py", line 1008, in render
    return self.environment.handle_exception(exc_info, True)
  File "/usr/local/virtualenv/1.3dev/lib/python2.7/site-packages/jinja2/environment.py", line 780, in handle_exception
    reraise(exc_type, exc_value, tb)
  File "/usr/local/virtualenv/1.3dev/lib/python2.7/site-packages/trac/wiki/templates/wiki_delete.html", line 12, in top-level template code
    # extends 'layout.html'
  File "/usr/local/virtualenv/1.3dev/lib/python2.7/site-packages/trac/templates/layout.html", line 12, in top-level template code
    # import "macros.html" as jmacros with context
  File "/usr/local/virtualenv/1.3dev/lib/python2.7/site-packages/trac/templates/theme.html", line 22, in top-level template code
    # block body
  File "/usr/local/virtualenv/1.3dev/lib/python2.7/site-packages/trac/templates/theme.html", line 157, in block "body"
    # block content
  File "/usr/local/virtualenv/1.3dev/lib/python2.7/site-packages/trac/wiki/templates/wiki_delete.html", line 133, in block "content"
    ngettext("%(num)d version", "all %(num)d versions", num=versions)
  File "/usr/local/virtualenv/1.3dev/lib/python2.7/site-packages/trac/util/translation.py", line 219, in ngettext
    return _ngettext()
  File "/usr/local/virtualenv/1.3dev/lib/python2.7/site-packages/trac/util/translation.py", line 216, in _ngettext
    return safefmt(trans, kwargs)
  File "/usr/local/virtualenv/1.3dev/lib/python2.7/site-packages/trac/util/translation.py", line 31, in safefmt
    return string % kwargs
TypeError: %d format: a number is required, not Undefined

Attachments (0)

Change History (1)

comment:1 by Ryan J Ollos, 5 years ago

Milestone: 1.3.2
Resolution: duplicate
Status: newclosed

Duplicate of #12738.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The ticket will remain with no owner.
The resolution will be deleted. Next status will be 'reopened'.
to The owner will be changed from (none) to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.