Edgewall Software
Modify

Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#12689 closed defect (fixed)

Timeline shows incorrect date in heading

Reported by: Ryan J Ollos Owned by: Ryan J Ollos
Priority: normal Milestone: 1.3.2
Component: timeline Version:
Severity: normal Keywords: datetime
Cc: Branch:
Release Notes:

Fixed timeline date headings not localized (regression in Jinja2 porting).

API Changes:

Description (last modified by Ryan J Ollos)

The server is something like +8 hours from my TZ and I've set my local timezone in preferences. The time is correct for the timeline entry but the date in the heading is +1 day. I tested the behavior with demo-1.2 and the issue isn't seen there.

Attachments (1)

Screen Shot 2017-02-14 at 17.27.32.png (64.2 KB ) - added by Ryan J Ollos 3 years ago.

Download all attachments as: .zip

Change History (9)

by Ryan J Ollos, 3 years ago

comment:1 by Ryan J Ollos, 3 years ago

Description: modified (diff)
Keywords: datetime added

comment:2 by Ryan J Ollos, 3 years ago

Owner: set to Ryan J Ollos
Status: newassigned

Proposed changes in [3b5bec52/rjollos.git].

comment:3 by Ryan J Ollos, 3 years ago

Release Notes: modified (diff)

comment:4 by Christian Boos, 3 years ago

Be careful, I had a regression on this already, in the Jinja branch. Around the turn of the year, key_date was format_date(date) instead of format_date(date, format='iso8601'), and we had some mix-up in the order of the days, with the January days coming after the December ones.

I just tried again with your changes, and the localization preferences set to "Date format: you language settings" and "Language: English/US":

  • Mar 9, 2017:
  • Mar 8, 2017:
  • Mar 7, 2017:
  • Mar 6, 2017:
  • Mar 5, 2017:
  • Mar 22, 2017: Today
  • Mar 21, 2017: Yesterday
  • Mar 20, 2017:
  • Mar 2, 2017:
  • Mar 19, 2017:

comment:5 by Ryan J Ollos, 3 years ago

Okay, we'll need to separate the presentation and sorting then. Current implementation has regressions:

Last edited 3 years ago by Ryan J Ollos (previous) (diff)

comment:6 by Ryan J Ollos, 3 years ago

The changes in [945c6277/rjollos.git] pass truncated datetime objects to the template and format the datetime object in the template. I used a truncated datetime object rather than a date object because using a date object introduces problems performing addition and subtraction between datetime and date objects.

Last edited 3 years ago by Ryan J Ollos (previous) (diff)

comment:7 by Ryan J Ollos, 3 years ago

Resolution: fixed
Status: assignedclosed

Committed to trunk in r15713.

comment:8 by Ryan J Ollos, 3 years ago

Regression due to r15713 reported in #12799.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Ryan J Ollos.
The resolution will be deleted. Next status will be 'reopened'.
to as closed The owner will be changed from Ryan J Ollos to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.