Edgewall Software
Modify

Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#12520 closed defect (duplicate)

IndexError: pop from empty list

Reported by: pfsc Owned by:
Priority: normal Milestone:
Component: rendering Version: 1.0.11
Severity: normal Keywords:
Cc: Branch:
Release Notes:
API Changes:
Internal Changes:

Description

How to Reproduce

While doing a GET operation on /attachment/ticket/3433/, Trac issued an internal error.

(please provide additional details here)

Request parameters:

{u'action': u'new', 'path': u'3433/', 'realm': u'ticket'}

User agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.11; rv:47.0) Gecko/20100101 Firefox/47.0

System Information

Trac 1.0.11
Babel 2.3.4
Docutils 0.8.1
Genshi 0.7 (with speedups)
mod_wsgi 3.3 (WSGIProcessGroup WSGIApplicationGroup %{GLOBAL})
Pygments 1.4
pysqlite 2.6.0
Python 2.7.3 (default, Jun 22 2015, 19:44:33)
[GCC 4.6.3]
pytz 2016.4
RPC 1.1.3
setuptools 23.0.0
SQLite 3.7.9
Subversion 1.9.4 (r1740329)
jQuery 1.7.2
jQuery UI 1.8.21
jQuery Timepicker 1.0.1

Enabled Plugins

TracAccountManager 0.4.4
TracCustomFieldAdmin 0.2.12
TracWorkflowAdmin 0.12.0.2
TracXMLRPC 1.1.3

Python Traceback

Traceback (most recent call last):
  File "/usr/local/lib/python2.7/dist-packages/trac/web/main.py", line 562, in _dispatch_request
    dispatcher.dispatch(req)
  File "/usr/local/lib/python2.7/dist-packages/trac/web/main.py", line 269, in dispatch
    iterable=chrome.use_chunked_encoding)
  File "/usr/local/lib/python2.7/dist-packages/trac/web/chrome.py", line 1114, in render_template
    encoding='utf-8')
  File "/usr/local/lib/python2.7/dist-packages/genshi/core.py", line 184, in render
    return encode(generator, method=method, encoding=encoding, out=out)
  File "/usr/local/lib/python2.7/dist-packages/genshi/output.py", line 58, in encode
    for chunk in iterator:
  File "/usr/local/lib/python2.7/dist-packages/genshi/output.py", line 350, in __call__
    for kind, data, pos in stream:
  File "/usr/local/lib/python2.7/dist-packages/genshi/output.py", line 829, in __call__
    for kind, data, pos in stream:
  File "/usr/local/lib/python2.7/dist-packages/genshi/output.py", line 669, in __call__
    for kind, data, pos in stream:
  File "/usr/local/lib/python2.7/dist-packages/genshi/output.py", line 774, in __call__
    for kind, data, pos in chain(stream, [(None, None, None)]):
  File "/usr/local/lib/python2.7/dist-packages/genshi/output.py", line 594, in __call__
    for ev in stream:
  File "/usr/local/lib/python2.7/dist-packages/genshi/core.py", line 289, in _ensure
    for event in stream:
  File "/usr/local/lib/python2.7/dist-packages/genshi/core.py", line 289, in _ensure
    for event in stream:
  File "/usr/local/lib/python2.7/dist-packages/trac/web/chrome.py", line 1320, in _strip_accesskeys
    for kind, data, pos in stream:
  File "/usr/local/lib/python2.7/dist-packages/genshi/core.py", line 289, in _ensure
    for event in stream:
  File "/usr/local/lib/python2.7/dist-packages/trac/web/chrome.py", line 1309, in _generate
    for kind, data, pos in stream:
  File "/usr/local/lib/python2.7/dist-packages/genshi/template/base.py", line 618, in _include
    for event in stream:
  File "/usr/local/lib/python2.7/dist-packages/genshi/template/markup.py", line 378, in _match
    ctxt, start=idx + 1, **vars):
  File "/usr/local/lib/python2.7/dist-packages/genshi/template/markup.py", line 378, in _match
    ctxt, start=idx + 1, **vars):
  File "/usr/local/lib/python2.7/dist-packages/genshi/template/markup.py", line 326, in _match
    for event in stream:
  File "/usr/local/lib/python2.7/dist-packages/genshi/template/base.py", line 558, in _flatten
    for kind, data, pos in stream:
  File "/usr/local/lib/python2.7/dist-packages/genshi/core.py", line 289, in _ensure
    for event in stream:
  File "/usr/local/lib/python2.7/dist-packages/genshi/path.py", line 588, in _generate
    subevent = next()
  File "/usr/local/lib/python2.7/dist-packages/genshi/template/base.py", line 618, in _include
    for event in stream:
  File "/usr/local/lib/python2.7/dist-packages/genshi/template/markup.py", line 315, in _strip
    event = next()
  File "/usr/local/lib/python2.7/dist-packages/genshi/template/base.py", line 558, in _flatten
    for kind, data, pos in stream:
  File "/usr/local/lib/python2.7/dist-packages/genshi/core.py", line 289, in _ensure
    for event in stream:
  File "/usr/local/lib/python2.7/dist-packages/genshi/path.py", line 588, in _generate
    subevent = next()
  File "/usr/local/lib/python2.7/dist-packages/genshi/template/base.py", line 618, in _include
    for event in stream:
  File "/usr/local/lib/python2.7/dist-packages/genshi/template/markup.py", line 315, in _strip
    event = next()
  File "/usr/local/lib/python2.7/dist-packages/genshi/template/base.py", line 558, in _flatten
    for kind, data, pos in stream:
  File "/usr/local/lib/python2.7/dist-packages/genshi/filters/i18n.py", line 178, in _generate
    for event in msgbuf.translate(gettext(msgbuf.format())):
  File "/usr/local/lib/python2.7/dist-packages/genshi/filters/i18n.py", line 1051, in translate
    events = self.events[order].pop(0)
IndexError: pop from empty list

Attachments (0)

Change History (3)

comment:1 by Jun Omae, 4 years ago

That is a duplicate of #11184 and a Genshi issue (genshi:#566).

Please try to downgrade Genshi 0.6.

comment:2 by Jun Omae, 4 years ago

Resolution: duplicate
Status: newclosed

comment:3 by Jun Omae, 4 years ago

Component: generalrendering

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The ticket will remain with no owner.
The resolution will be deleted. Next status will be 'reopened'.
to The owner will be changed from (none) to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.