Edgewall Software
Modify

Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#12319 closed enhancement (duplicate)

TitleIndex macro: Plugin custom features / sort modes

Reported by: anonymous Owned by:
Priority: normal Milestone:
Component: wiki system Version:
Severity: normal Keywords: Macro TitleIndex
Cc: Branch:
Release Notes:
API Changes:
Internal Changes:

Description

It would be great if Trac would allow plugins to add new features to core macros like TitleIndex. This should allow plugins to implement things that are maybe out-of-scope for Trac core like custom sort modes for:

Attachments (0)

Change History (1)

comment:1 by Ryan J Ollos, 6 years ago

Resolution: duplicate
Status: newclosed

I'm not sure how we could allow plugins to add new features. You can inherit from TitleIndex macro and create your own custom macro.

Duplicate of #10323. Patch is the same as what you posted to that ticket.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The ticket will remain with no owner.
The resolution will be deleted. Next status will be 'reopened'.
to The owner will be changed from (none) to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.