Edgewall Software
Modify

Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#12235 closed defect (duplicate)

TypeError: unsupported operand type(s) for +: 'NoneType' and 'NoneType'

Reported by: martin Owned by:
Priority: normal Milestone:
Component: plugin/git Version: 1.0.9
Severity: normal Keywords:
Cc: Branch:
Release Notes:
API Changes:
Internal Changes:

Description

How to Reproduce

While doing a GET operation on /changeset/9d7dc734e5f06d9adf5ff97153401863ac7705de, Trac issued an internal error.

We only have updated the submodule reference. No other changes.

Request parameters:

{'new': u'9d7dc734e5f06d9adf5ff97153401863ac7705de'}

User agent: Mozilla/5.0 (X11; OpenBSD amd64; rv:33.0) Gecko/20100101 Firefox/33.0

System Information

Trac 1.0.9
Babel 0.9.6
Docutils 0.8.1
Genshi 0.6 (with speedups)
GIT 1.7.10.4
Pygments 1.5
pysqlite 2.6.0
Python 2.7.3 (default, Jan 2 2013, 13:56:14)
[GCC 4.7.2]
pytz 2012c
setuptools 0.6
SQLite 3.7.13
jQuery 1.7.2
jQuery UI 1.8.21
jQuery Timepicker 1.0.1

Enabled Plugins

TracPaste 0.2.3

Python Traceback

Traceback (most recent call last):
  File "/usr/local/lib/python2.7/dist-packages/trac/web/main.py", line 554, in _dispatch_request
    dispatcher.dispatch(req)
  File "/usr/local/lib/python2.7/dist-packages/trac/web/main.py", line 247, in dispatch
    resp = chosen_handler.process_request(req)
  File "/usr/local/lib/python2.7/dist-packages/trac/versioncontrol/web_ui/changeset.py", line 353, in process_request
    self._render_html(req, repos, chgset, restricted, xhr, data)
  File "/usr/local/lib/python2.7/dist-packages/trac/versioncontrol/web_ui/changeset.py", line 588, in _render_html
    diff_bytes += _estimate_changes(old_node, new_node)
  File "/usr/local/lib/python2.7/dist-packages/trac/versioncontrol/web_ui/changeset.py", line 538, in _estimate_changes
    return old_size + new_size
TypeError: unsupported operand type(s) for +: 'NoneType' and 'NoneType'

Attachments (0)

Change History (2)

comment:1 by Jun Omae, 7 years ago

Milestone: 1.0.10
Resolution: duplicate
Status: newclosed

A duplicate of #10732 and #10162.

comment:2 by Jun Omae, 7 years ago

Component: generalplugin/git

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The ticket will remain with no owner.
The resolution will be deleted. Next status will be 'reopened'.
to The owner will be changed from (none) to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.